Bug 996998 - glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64 postinstall - /usr/bin/chmod +x /usr/share/glusterfs/scripts/get-gfid.sh
glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64 postinstall - /usr/bin/...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Venky Shankar
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 09:02 EDT by Jiri Belka
Modified: 2013-09-23 18:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.20rhs-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:38:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log of the script, rpm debug (31.41 KB, application/x-tar)
2013-08-14 09:02 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-08-14 09:02:21 EDT
Created attachment 786531 [details]
log of the script, rpm debug

Description of problem:
On RHEL `chmod' is in /bin/chmod, not /usr/bin/chmod

D:   install: %post(glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64) scriptlet start
D:   install: %post(glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64)      execv(/bin/sh) pid 8620
+ /usr/bin/chmod +x /usr/share/glusterfs/scripts/get-gfid.sh
/var/tmp/rpm-tmp.i2JOAd: line 2: /usr/bin/chmod: No such file or directory
D:   install: waitpid(8620) rc 8620 status 7f00 secs 0.004
warning: %post(glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64) scriptlet failed, exit status 127

# rpm --scripts -q glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64
postinstall scriptlet (using /bin/sh):
/usr/bin/chmod +x /usr/share/glusterfs/scripts/get-gfid.sh

#restart glusterd.
#if [ $1 -ge 1 ]; then
#    /sbin/service glusterd condrestart &>/dev/null ;#fi

# which chmod
/bin/chmod

# ls -l /usr/bin/chmod
ls: cannot access /usr/bin/chmod: No such file or directory


Version-Release number of selected component (if applicable):
glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64

How reproducible:
100%

Steps to Reproduce:
1. check glusterfs-geo-replication-3.4.0.19rhs-2.el6rhs.x86_64 specfile
2.
3.

Actual results:
bad path from chmod in postinstall scriptlet

Expected results:
/bin/chmod

Additional info:
Comment 1 Amar Tumballi 2013-08-14 09:12:56 EDT
had to change it to /bin/chmod in post...
Comment 3 Sudhir D 2013-08-15 08:02:21 EDT
This is fixed in the latest build. Marking as verified.
Comment 4 Scott Haines 2013-09-23 18:38:51 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:30 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.