Bug 997000 - [WA portal] both garunteed memory and disabled ballon can be set together
[WA portal] both garunteed memory and disabled ballon can be set together
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nobody's working on this, feel free to take it
Lukas Svaty
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 09:05 EDT by Lukas Svaty
Modified: 2016-02-10 15:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 09:45:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Svaty 2013-08-14 09:05:53 EDT
Description of problem:
In webadmin portal user is able to disable balloon by unchecking Memory balloon device enabled. At the same time he can set the garunteed memory for VM. What is the desired behaviour in this case?

Version-Release number of selected component (if applicable):
is10

Steps to Reproduce:
1. Set Memory to 2048MB
2. Set Physical memory guaranteed to 1024MB 
3. Uncheck option "Memory balloon device enabled" in Resource allocation tab
4. Add Vm

Actual results:
Behaviour should be that balloon is disabled and option for physical memory guaranteed is unnecessary and not used. User should not be able to disable balloon device and set guaranteed memory of VM. 

Expected results:
When balloon is disabled. User/Admin should not be able to set guaranteed memory.

Additional info:
Vm memory -> Vm menu -> System
Balloon options -> Vm menu -> Resource allocation
Comment 1 Itamar Heim 2013-08-14 10:38:02 EDT
that would be the default configuration for anyone upgrading a VM with guaranteed memory in 3.2 when cluster moved to 3.3, so i don't see why it should be blocked?
Comment 2 Lukas Svaty 2013-08-14 10:48:51 EDT
User could think that while balloon is disabled guaranteed memory somehow count into memory management of VM.

I don't see reason why guaranteed memory should be configurable when balloon is disabled.
Comment 3 Doron Fediuck 2013-08-15 03:13:40 EDT
(In reply to Lukas Svaty from comment #2)
> User could think that while balloon is disabled guaranteed memory somehow
> count into memory management of VM.
> 
> I don't see reason why guaranteed memory should be configurable when balloon
> is disabled.

Lukas,
First of all Itamar is right, this should be default for upgraded VMs
with no balloon device.

There are 2 things I'd like to clarify for this context;

1. There's a big difference between a VM having a balloon device, and
mom using the balloon device:

- By default every new VM will have a balloon device, unless specifically
  removed by the creator.

- MoM ballooning is a cluster level functionality, due to migration
  implications on a ballooned VM. Be default, all clusters do not use
  ballooning, as this may be offensive in some setups.

So the sane default of the system is for every new VM (and some upgraded ones)
to have a balloon device, while it will not be used until the cluster policy
will be modified to use balloon optimization.

2. Guaranteed memory is needed for several reasons;
- Allow hard limits at host level (unsupported yet).
- Scheduling calculations which use the minimum as KSM is optimizing.
- Providing a floor for mom during ballooning.
 
In this issue, you need to consider all the above to understand minimum
guaranteed is actually needed regardless of the balloon device status.
As this data will be used for scheduling and going forward for hard limits.

I'm fine with making this explanation a release note to close the issue.

Note You need to log in before you can comment on or make changes to this bug.