Bug 997018 - Sinatra 1.3.2 bug found upstream
Sinatra 1.3.2 bug found upstream
Status: CLOSED ERRATA
Product: Red Hat Software Collections
Classification: Red Hat
Component: rubygem-sinatra (Show other bugs)
ruby193
Unspecified Unspecified
unspecified Severity high
: rc
: 1.0
Assigned To: Vít Ondruch
Iveta Wiedermann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 09:41 EDT by Charles Crouch
Modified: 2016-04-05 06:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: ruby193-rubygem-sinatra-1.3.2-12.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 13:45:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2013-08-14 09:41:05 EDT
The version of sinatra in SCL, v1.3.2, seems to have a pretty bad bug in it:

https://github.com/sinatra/sinatra/issues/452

This impacts Foreman which uses ruby SCL, but this bug would impact other apps too.

The rack-protection gem would also need to be updated since versions of sinatra after 1.3.2 pull in newer versions, e.g 1.5.0
Comment 2 Vít Ondruch 2013-08-15 04:50:45 EDT
Don't think it is right time for Rebase, especially it would need rebase to Sinatra 1.4.x. I would much prefer just backport of the fix (seems to be straight forward, although I have not tried it yet).
Comment 8 errata-xmlrpc 2013-09-10 13:45:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1249.html

Note You need to log in before you can comment on or make changes to this bug.