Bug 997022 - RTGov is included in ER1 Aug 12 update, but GadgetServer testing is blocked - http://localhost:8080/gadget-web/ - returns 404 error
RTGov is included in ER1 Aug 12 update, but GadgetServer testing is blocked -...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER3
: ---
Assigned To: Len DiMaggio
Jiri Sedlacek
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 09:50 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 13:38:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Len DiMaggio 2013-08-14 09:50:49 EDT
Description of problem:

The wars are being loaded - but the page is not accessible:

09:31:30,916 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-commons-idp.war" (runtime-name : "overlord-commons-idp.war")
09:31:30,917 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "switchyard-bpel-console-server.war" (runtime-name : "switchyard-bpel-console-server.war")
09:31:30,917 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "dtgov-ui-war.war" (runtime-name : "dtgov-ui-war.war")
09:31:30,918 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "s-ramp-ui.war" (runtime-name : "s-ramp-ui.war")
09:31:30,918 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "s-ramp-server.war" (runtime-name : "s-ramp-server.war")
09:31:30,919 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "switchyard-bpel-console.war" (runtime-name : "switchyard-bpel-console.war")
09:31:30,919 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-rtgov-acs.war" (runtime-name : "overlord-rtgov-acs.war")
09:31:30,919 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-rtgov.war" (runtime-name : "overlord-rtgov.war")
09:31:30,919 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "gadget-web.war" (runtime-name : "gadget-web.war")
09:31:30,919 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "overlord-rtgov-epn.war" (runtime-name : "overlord-rtgov-epn.war")
09:31:30,919 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "gadgets.war" (runtime-name : "gadgets.war")
09:31:30,919 INFO  [org.jboss.as.server] (ServerService Thread Pool -- 27) JBAS018559: Deployed "dtgov-war.war" (runtime-name : "dtgov-war.war")





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Len DiMaggio 2013-08-14 09:53:38 EDT
Related to:  https://bugzilla.redhat.com/show_bug.cgi?id=993272
Comment 3 Gary Brown 2013-08-14 09:58:33 EDT
Could the full server.log be attached please.
Comment 4 Gary Brown 2013-08-14 10:29:25 EDT
Could not reproduce.

I downloaded ER1 and copied it on top of EAP 6.1. I then started it using:

./standalone.sh -c standalone-full.xml

It started with no errors, and http://localhost:8080/gadget-web showed the expected page.

Are there any differences to the steps you performed?
Comment 5 Len DiMaggio 2013-09-05 09:47:16 EDT
Hi Gary - I am doing the same steps and am seeing:

JBWEB000065: HTTP Status 404 - /gadget-web

JBWEB000309: type JBWEB000067: Status report

JBWEB000068: message /gadget-web

JBWEB000069: description JBWEB000124: The requested resource is not available.
JBoss Web/7.2.0.Final-redhat-1
Comment 6 Len DiMaggio 2013-09-24 13:36:54 EDT
Not an issue in ER3.

Note You need to log in before you can comment on or make changes to this bug.