Bug 997044 - Menus not working when accessed by keyboard
Menus not working when accessed by keyboard
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 10:39 EDT by gilgamesh2k
Modified: 2013-08-15 09:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 06:27:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gilgamesh2k 2013-08-14 10:39:13 EDT
Description of problem:
I'm using a plugin for searching selected text - Yet Another Context Search 1.3.1.
When I do select the search provider by clicking right mouse button and choosing from the list, it works. Doing so by clicking the right mouse button key on the keyboard and selecting the provider doesn't work. Looks like it does, e.g. I move trough the menu and the submenu opens, but when I press Enter, nothing happens.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jan Horak 2013-08-15 06:27:44 EDT
Thanks for bug report. The problem lies in Yet Another Context Search extension. It add event handler in popmenu only to 'click' event. It should add event handler to 'command' instead. I can't find contact to developers of extension, if you will be more successful, please let them know. Thanks.
Comment 2 gilgamesh2k 2013-08-15 09:38:41 EDT
Thank you for your response. I did report this via mozzila extension review page. For the moment I choose another extension with this functionality :-)

Note You need to log in before you can comment on or make changes to this bug.