Bug 997075 - CartridgeRepository.erase does not respect latest cartridge version default keys
CartridgeRepository.erase does not respect latest cartridge version default keys
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Morie
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 11:30 EDT by Paul Morie
Modified: 2015-05-14 19:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:51:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Morie 2013-08-14 11:30:31 EDT
Currently, CartridgeRepository.erase does not maintain integrity of the latest cartridge version default keys.  Erase should maintain the integrity of these keys.
Comment 2 Meng Bo 2013-08-23 06:47:34 EDT
Tested on past few days, and no regression issue found for the oo-admin-cartridge.


Move bug to verified.
Comment 3 Xiaoli Tian 2013-08-23 06:53:08 EDT
Verified it on devenv-stage_425, since not sure what does the default keys mean, we just regression test the oo-admin-cartridge-erase, it works normally:

[root@ip-10-100-253-67 ~]# oo-admin-cartridge -a list|grep php
(redhat, php, 5.3, 0.0.3)
(redhat, php, 5.3, 0.0.5)
(redhat, php, 5.3, 0.0.4)
[root@ip-10-100-253-67 ~]# oo-admin-cartridge -a erase -n php -v 5.3 -c 0.0.4
succeeded
[root@ip-10-100-253-67 ~]# oo-admin-cartridge -a list|grep php
(redhat, php, 5.3, 0.0.3)
(redhat, php, 5.3, 0.0.5)
[root@ip-10-100-253-67 ~]# oo-admin-cartridge -a erase -n php -v 5.3 -c 0.0.5
succeeded
[root@ip-10-100-253-67 ~]# oo-admin-cartridge -a list|grep php
(redhat, php, 5.3, 0.0.3)


Move it to verified for now, if there's any more check points need to re-test, please leave comment to this bug.

Note You need to log in before you can comment on or make changes to this bug.