Bug 997076 - abrt-handle-event segfaults while processing coredump
abrt-handle-event segfaults while processing coredump
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: satyr (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
: 1001894 (view as bug list)
Depends On:
Blocks: 999030
  Show dependency treegraph
 
Reported: 2013-08-14 11:30 EDT by Tomáš Bžatek
Modified: 2016-11-30 19:44 EST (History)
14 users (show)

See Also:
Fixed In Version: satyr-0.7-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 21:50:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compressed coredump dir (658.59 KB, application/x-xz)
2013-08-14 11:30 EDT, Tomáš Bžatek
no flags Details
ccpp-2013-08-12-16:46:52-5078.tar.xz (629.14 KB, application/x-xz)
2013-08-14 11:39 EDT, Tomáš Bžatek
no flags Details

  None (edit)
Description Tomáš Bžatek 2013-08-14 11:30:57 EDT
Created attachment 786577 [details]
compressed coredump dir

kernel: abrt-handle-eve[19859]: segfault at 0 ip 00007efffbbef0a4 sp 00007fff3d918840 error 4 in libsatyr.so.1.0.0[7efffbb98000+139000]


journal excerpt (recent first):
> Aug 14 17:14:56 localhost.localdomain abrtd[22518]: Deleting problem directory '/var/tmp/abrt/ccpp-2013-08-14-17:14:48-19407'
> Aug 14 17:14:56 localhost.localdomain abrtd[22518]: 'post-create' on '/var/tmp/abrt/ccpp-2013-08-14-17:14:48-19407' killed by signal 11
> Aug 14 17:14:56 localhost.localdomain abrt[19481]: Saved core dump of pid 19446 (/usr/libexec/abrt-handle-event) to /var/tmp/abrt/abrt-handle-event-coredump (1748992 bytes)
> Aug 14 17:14:56 localhost.localdomain kernel: abrt-handle-eve[19446]: segfault at 0 ip 00007feafa9a90a4 sp 00007fff8ab62bc0 error 4 in libsatyr.so.1.0.0[7feafa952000+139000]
> Aug 14 17:14:50 localhost.localdomain abrtd[22518]: Generating backtrace
> Aug 14 17:14:50 localhost.localdomain abrtd[22518]: Generating core_backtrace
> Aug 14 17:14:49 localhost.localdomain abrtd[22518]: Can't load public GPG key /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
> Aug 14 17:14:49 localhost.localdomain abrt[19445]: Saved core dump of pid 19407 (/usr/sbin/cimserver) to /var/tmp/abrt/ccpp-2013-08-14-17:14:48-19407 (30703616 bytes)
> Aug 14 17:14:49 localhost.localdomain abrtd[22518]: Directory 'ccpp-2013-08-14-17:14:48-19407' creation detected
> Aug 14 17:14:48 localhost.localdomain kernel: cimserver[19423]: segfault at 7f7ae400d1d0 ip 00007f7ae400d1d0 sp 00007f7ae8bfcc68 error 15


Stacktrace of abrt-handle-event:

Thread 1 (Thread 0x7feafbc37840 (LWP 19446)):
#0  sr_thread_frame_count (thread=0x0) at generic_thread.c:152
#1  0x00007feafbc61b9d in core_backtrace_is_duplicate (
    bt2_text=0x7feafd7f0b00 "{   \"signal\": 11\n,   \"executable\": \"/usr/sbin/cimserver\"\n,   \"stacktrace\":\n      [ {   \"frames\":\n", ' ' <repeats 14 times>, "[ {   \"address\": 140333559571120\n", ' ' <repeats 16 times>, ",   \"build_id\": \"dc51e65a56da76bf134beb2"..., bt1=<optimized out>) at abrt-handle-event.c:65
#2  dup_corebt_compare (dd=0x7feafd7ec2d0) at abrt-handle-event.c:178
#3  is_crash_a_dup (dump_dir_name=<optimized out>, param=<optimized out>) at abrt-handle-event.c:274
#4  0x00007feafb06485b in consume_event_command_output (state=state@entry=0x7feafd7e37e0, dump_dir_name=dump_dir_name@entry=0x7feafd7e3630 "/var/tmp/abrt/ccpp-2013-08-14-17:14:48-19407") at run_event.c:599
#5  0x00007feafb0648ab in run_event_on_dir_name (state=state@entry=0x7feafd7e37e0, dump_dir_name=dump_dir_name@entry=0x7feafd7e3630 "/var/tmp/abrt/ccpp-2013-08-14-17:14:48-19407", event=0x7fff8ab63f04 "post-create") at run_event.c:617
#6  0x00007feafbc6168c in main (argc=<optimized out>, argv=0x7fff8ab62ff0) at abrt-handle-event.c:361


This is satyr-0.6-1.fc20.x86_64 and abrt-libs-2.1.6-3.fc20.x86_64
Comment 1 Tomáš Bžatek 2013-08-14 11:39:32 EDT
Created attachment 786580 [details]
ccpp-2013-08-12-16:46:52-5078.tar.xz

Older coredump directory found in /var/tmp/abrt
Comment 2 Jakub Filak 2013-08-16 06:07:53 EDT
Thank you for the bug report.

Fixed in upstream git repository:

commit 2f925098c65014ed69c130d72823f15520565807
Author: Jakub Filak <jfilak@redhat.com>
Date:   Fri Aug 16 10:43:55 2013 +0200

    Return preselected crash thread of core stacktrace
    
    Closes rhbz#997076
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Martin Milata <mmilata@redhat.com>
Comment 3 Fedora Update System 2013-08-26 12:18:09 EDT
satyr-0.7-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/satyr-0.7-1.fc18
Comment 4 Fedora Update System 2013-08-26 12:18:31 EDT
satyr-0.7-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/satyr-0.7-1.fc19
Comment 5 Fedora Update System 2013-08-27 19:25:11 EDT
Package satyr-0.7-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing satyr-0.7-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15360/satyr-0.7-1.fc19
then log in and leave karma (feedback).
Comment 6 Lloyd Kvam 2013-09-02 10:46:58 EDT
I think the underlying problem is a missing symbolic link.  Here's my fix:

  cd /etc/pki/rpm-gpg/
  ln -s RPM-GPG-KEY-fedora-19-primary RPM-GPG-KEY-fedora

This was also affecting virt-manager.  I could start vi9rt-manager in debug mode.  But the normal startup failed.  Once I added the symbolic link for

RPM-GPG-KEY-fedora

it worked properly.  The real bug may be in fedup which is what I used to get from Fedora-18 to fedora-19.
Comment 7 Jiri Moskovcak 2013-09-03 02:20:55 EDT
(In reply to Lloyd Kvam from comment #6)
> I think the underlying problem is a missing symbolic link.  Here's my fix:
> 
>   cd /etc/pki/rpm-gpg/
>   ln -s RPM-GPG-KEY-fedora-19-primary RPM-GPG-KEY-fedora
> 
> This was also affecting virt-manager.  I could start vi9rt-manager in debug
> mode.  But the normal startup failed.  Once I added the symbolic link for
> 
> RPM-GPG-KEY-fedora
> 
> it worked properly.  The real bug may be in fedup which is what I used to
> get from Fedora-18 to fedora-19.

It's actually a different problem fixed in commit: 

commit 4d6a4340a065239a0f11dec539c2412ef74a38e7
Author: Jiri Moskovcak <jmoskovc@redhat.com>
Date:   Wed Aug 28 18:55:41 2013 +0200

    fixed the gpg keys loading - closes #686
    
    Signed-off-by: Jiri Moskovcak <jmoskovc@redhat.com>
    Signed-off-by: Richard Marko <rmarko@redhat.com>
Comment 8 Jakub Filak 2013-09-09 04:20:31 EDT
I forgot that we have to deal with already created dump directories with core_bactrace elements without crash thread. I've sent a patch set fixing this issue:
https://lists.fedorahosted.org/pipermail/crash-catcher/2013-August/005276.html
Comment 9 Richard Marko 2013-09-09 10:08:03 EDT
(In reply to Jakub Filak from comment #8)
> I forgot that we have to deal with already created dump directories with
> core_bactrace elements without crash thread. I've sent a patch set fixing
> this issue:
> https://lists.fedorahosted.org/pipermail/crash-catcher/2013-August/005276.
> html

Applied.

commit f710f15b32dc9088c49d4a2737cc95f2bd9b8a7a
Author: Jakub Filak <jfilak@redhat.com>
Date:   Fri Aug 23 10:20:17 2013 +0200

    abrt-handle-event: add check for missing crash thread
    
    Just to be sure. satyr should always find a crash thread.
    
    Related to rhbz#997076
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Richard Marko <rmarko@redhat.com>
Comment 10 Richard Marko 2013-09-09 10:10:51 EDT
*** Bug 1001894 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2013-09-11 21:50:43 EDT
satyr-0.7-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-09-11 21:58:34 EDT
satyr-0.7-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.