Bug 997078 - Downloadable cartridges missing debug info
Downloadable cartridges missing debug info
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rajat Chopra
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 11:38 EDT by Mike McGrath
Modified: 2015-05-14 20:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:51:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McGrath 2013-08-14 11:38:16 EDT
Description of problem:

I'm working on a blog post which lets users start with a broken cartridge and go through the debugging steps.  Here's the sample manifest.yaml that is intentionally missing the Cartridge-Vendor field:

https://raw.github.com/mmcgrath-openshift/openshift-httpd-cartridge-broken/master/metadata/manifest.yml

It used to output:

Unable to complete the requested operation due to: '' does not match pattern /\A[a-z][a-z0-9_]*\z/.: 'Cartridge-Vendor'. Reference ID: d2a2da41d00a16a17ad9d116e02d98c5

Now it outputs:

Invalid manifest file from url 'https://raw.github.com/mmcgrath-openshift/openshift-httpd-cartridge-broken/master/metadata/manifest.yml'
Comment 1 Rajat Chopra 2013-08-16 09:29:42 EDT
fixed with pull request : https://github.com/openshift/origin-server/pull/3384
Comment 2 Jianwei Hou 2013-08-18 23:31:16 EDT
Verified on devenv_3671

More debug info is displayed.

$ rhc create-app app1 https://raw.github.com/mmcgrath-openshift/openshift-httpd-cartridge-broken/master/metadata/manifest.yml --no-git --no-dns
The cartridge 'https://raw.github.com/mmcgrath-openshift/openshift-httpd-cartridge-broken/master/metadata/manifest.yml' will be
downloaded and installed
Please sign in to start a new session to ec2-184-73-128-146.compute-1.amazonaws.com.
Password: 

Application Options
-------------------
  Namespace:  jhou
  Cartridges: https://raw.github.com/mmcgrath-openshift/openshift-httpd-cartridge-broken/master/metadata/manifest.yml
  Gear Size:  default
  Scaling:    no

Creating application 'app1' ... 
Invalid manifest file from url 'https://raw.github.com/mmcgrath-openshift/openshift-httpd-cartridge-broken/master/metadata/manifest.yml'
- '' does not match pattern /\A[a-z0-9](?:[a-z0-9_]*[a-z0-9]|)\z/.: 'Cartridge-Vendor'

Note You need to log in before you can comment on or make changes to this bug.