Bug 997085 - Privilege "SELinux User Map Administrators" does not list its permissions
Privilege "SELinux User Map Administrators" does not list its permissions
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 12:00 EDT by Namita Soman
Modified: 2014-06-17 20:11 EDT (History)
2 users (show)

See Also:
Fixed In Version: ipa-3.3.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:53:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attaching server install log (5.34 MB, application/x-gzip)
2013-08-19 11:52 EDT, Namita Soman
no flags Details

  None (edit)
Description Namita Soman 2013-08-14 12:00:32 EDT
Description of problem:
When verifying that all privileges have permissions assigned, "SELinux User Map Administrators" doesn't list any permissions. But the permission expected to be listed indicates that it is granted to this privilege. 
Behaviour was different in 6.4.

Using ipa-server-3.3.0-6.el7.x86_64
# ipa privilege-show "SELinux User Map Administrators"
  Privilege name: SELinux User Map Administrators
  Description: SELinux User Map Administrators

# ipa permission-show "modify selinux user maps"
  Permission name: Modify SELinux User Maps
  Permissions: write
  Attributes: cn, memberuser, memberhost, seealso, ipaselinuxuser, ipaenabledflag
  Subtree: ldap:///ipauniqueid=*,cn=usermap,cn=selinux,dc=testrelm,dc=com
  Granted to Privilege: SELinux User Map Administrators

Using ipa-server-3.0.0-26.el6_4.4.x86_64
# ipa privilege-show "SELinux User Map Administrators"
  Privilege name: SELinux User Map Administrators
  Description: SELinux User Map Administrators
  Permissions: modify selinux user maps, add selinux user maps, remove selinux user maps


# ipa permission-show "modify selinux user maps"
  Permission name: Modify SELinux User Maps
  Permissions: write
  Attributes: cn, memberuser, memberhost, seealso, ipaselinuxuser, ipaenabledflag
  Subtree: ldap:///ipauniqueid=*,cn=usermap,cn=selinux,dc=testrelm,dc=com
  Granted to Privilege: SELinux User Map Administrators

Version-Release number of selected component (if applicable):
ipa-server-3.3.0-6.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. ipa privilege-show "SELinux User Map Administrators"


Actual results:
No permissions listed

Expected results:
should list permissions: modify selinux user maps, add selinux user maps, remove selinux user maps


Additional info:
Comment 2 Martin Kosek 2013-08-15 02:32:55 EDT
This should have been fixed in 903343.

I tested this with ipa-server-3.3.0-6.el7.x86_64 and I did not reproduce the issue:

# ipa-server-install
# kinit admin
# ipa privilege-show "SELinux User Map Administrators"
  Privilege name: SELinux User Map Administrators
  Description: SELinux User Map Administrators
  Permissions: add selinux user maps, remove selinux user maps, modify selinux user maps

Namita, can you please provide ipaserver-install.log so that we can check the order and result of the LDAP updates done during the installation?
Comment 3 Namita Soman 2013-08-19 11:52:34 EDT
Created attachment 788135 [details]
attaching server install log
Comment 4 Rob Crittenden 2013-08-26 11:56:50 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3877
Comment 5 Ana Krivokapic 2013-09-18 09:57:42 EDT
I could not reproduce this either. I tried with ipa-server-3.3.0-6.el7.x86_64 and got the same result as Martin (comment #2).

OTOH, looking at the attached log file, I can see that all three permissions (add selinux user maps, modify selinux user maps, remove selinux user maps) get created before their parent privilege (SELinux User Map Administrators). I am not sure if this could be the cause of the bug.
Comment 6 Martin Kosek 2013-10-04 09:16:24 EDT
I found out that privilage member of task that was supposed to be run after the privileges were added were not run at all as there was a DN collision with other task being run earlier.

Long story short, the privilege fixup task is now being run correctly.

Fixed upstream:
master: b1451373c4f918621ce06d8144aaa63e1417777c
ipa-3-3: b32ed6d8ba85ec4baa1ebd69c564f2c8fcf7a3a6
Comment 8 Namita Soman 2013-11-18 15:03:13 EST
Verified using ipa-server-3.3.3-4.el7.x86_64

Automated test results:
:: [   PASS   ] :: Verify SELinux User Map Administrators has permissions (Expected 0, got 0)
Comment 9 Ludek Smid 2014-06-13 07:53:31 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.