Bug 997152 - Assigning an ISO Repo to a sync plan fails with error
Assigning an ISO Repo to a sync plan fails with error
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 15:13 EDT by Justin Sherrill
Modified: 2014-07-02 10:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:05:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the repos in rhel prd (100.72 KB, image/png)
2014-05-12 07:25 EDT, Kedar Bidarkar
no flags Details
rhel repo with sync-iso plan (58.50 KB, image/png)
2014-05-12 07:26 EDT, Kedar Bidarkar
no flags Details
sync plan with iso (35.17 KB, image/png)
2014-05-12 07:27 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Justin Sherrill 2013-08-14 15:13:17 EDT
Description of problem:

In mdp1 assigning a sync plan to a repository that is an 'ISO' repository will fail:



404 Resource Not Found (RestClient::ResourceNotFound)
{"http_request_method": "GET", "exception": null, "error_message": "Missing resource(s): importer=yum_importer", "_href": "/pulp/api/v2/repositories/Spectrum_Health-Red_Hat_Enterprise_Linux_Server-Red_Hat_Enterprise_Linux_6_Server_ISOs_x86_64_6_4/importers/yum_importer/schedules/sync/", "http_status": 404, "traceback": null, "resources": {"importer": "yum_importer"}}



Steps to Reproduce:
1. Import a manifest
2. Enable an ISO repo on the "Red hat Repos page"
3. Try to assign the repo to a sync plan



It looks like we aren't accounting for the fact that an iso repo has a different importer.
Comment 2 Justin Sherrill 2013-09-17 10:26:16 EDT
This is fixed in master, but the page itself was broken:

https://github.com/Katello/katello/pull/2967
Comment 4 Mike McCune 2013-10-17 17:04:41 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 5 Og Maciel 2014-04-28 13:40:12 EDT
This is blocked on https://bugzilla.redhat.com/show_bug.cgi?id=1092081
Comment 6 Kedar Bidarkar 2014-05-12 07:24:49 EDT
We are now able to sync/select ISO repos from the beta-snap4 build.

Also assigning RHEL product which has ISO repos to sync plan goes successful.

Note:- Looks like we can only attach an entire product now to sync plan.
Comment 7 Kedar Bidarkar 2014-05-12 07:25:53 EDT
Created attachment 894652 [details]
the repos in rhel prd
Comment 8 Kedar Bidarkar 2014-05-12 07:26:50 EDT
Created attachment 894653 [details]
rhel repo with sync-iso plan
Comment 9 Kedar Bidarkar 2014-05-12 07:27:19 EDT
Created attachment 894654 [details]
sync plan with iso
Comment 10 Bryan Kearney 2014-07-02 10:05:59 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.