Bug 997192 - oo-diagnostics does not check OPENSHIFT_NODE_PLUGINS in /etc/openshift/node.conf
oo-diagnostics does not check OPENSHIFT_NODE_PLUGINS in /etc/openshift/node.conf
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 17:33 EDT by Miciah Dashiel Butler Masters
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
The oo-diagnostics script did not check the OPENSHIFT_NODE_PLUGINS setting in the /etc/openshift/node.conf file, which is required for correct node operation. This has been fixed in the current release of OpenShift Enterprise, and the oo-diagnostics script now correctly checks for the OPENSHIFT_NODE_PLUGINS setting.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 09:24:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miciah Dashiel Butler Masters 2013-08-14 17:33:48 EDT
Description of problem:
oo-diagnostics does not check that value of the OPENSHIFT_NODE_PLUGINS setting in /etc/openshift/node.conf includes the unix_user_observer plug-in, which is necessary for the node's operation.


Version-Release number of selected component (if applicable):
OSE 1.2.


How reproducible:
Totally.


Steps to Reproduce:
1. Set up a new OpenShift node host.
2. Disable the unix_user_observer plug-in.
3. Run oo-diagnostics.


Actual results:
[root@node ~]# oo-diagnostics
NO ERRORS
[root@node ~]# ed /etc/openshift/node.conf
2855
/PLUGINS
OPENSHIFT_NODE_PLUGINS="openshift-origin-node/plugins/unix_user_observer"                                    # Extensions to load when customize/observe openshift-origin-node models
s/".*"/""
OPENSHIFT_NODE_PLUGINS=""                                    # Extensions to load when customize/observe openshift-origin-node models
wq
2807
[root@node ~]# oo-diagnostics
NO ERRORS


Expected results:
[root@node ~]# oo-diagnostics
FAIL: test_node_containerization_plugin
      The OPENSHIFT_NODE_PLUGINS setting in the node configuration file must include
      the openshift-origin-node/plugins/unix_user_observer plug-in in order for gear
      containerization using SELinux, cgroups, filesystem quotas, and pam_limits
      to function properly.

1 ERRORS
[root@node ~]#


Additional info:
In Origin, the containerization plug-ins supersede the unix_user_observer plug-in, so Origin's installation scripts disable unix_user_observer.  However, if one does the same on Enterprise 1.2, the node fails to create applications.  Someone ran into this issue when installing OpenShift Enterprise using Puppet scripts adapted from the OpenShift Origin scripts.
Comment 1 Miciah Dashiel Butler Masters 2013-08-14 17:34:23 EDT
https://github.com/openshift/enterprise-server/pull/118
Comment 4 Gaoyun Pei 2013-08-15 23:16:55 EDT
Verify this on puddle 1.2/2013-08-15.2

Change OPENSHIFT_NODE_PLUGINS="" in /etc/openshift/node.conf on node, run oo-diagnostics

[root@node ~]# oo-diagnostics 
FAIL: test_node_containerization_plugin
      The OPENSHIFT_NODE_PLUGINS setting in the node configuration file must include
      the openshift-origin-node/plugins/unix_user_observer plug-in in order for gear
      containerization using SELinux, cgroups, filesystem quotas, and pam_limits
      to function properly.

WARN: test_vhost_servernames
        The VirtualHost defined by default in /etc/httpd/conf.d/ssl.conf is not needed
        and can cause spurious warnings. Please remove it by running this command:

          sed -i '/VirtualHost/,/VirtualHost/ d' /etc/httpd/conf.d/ssl.conf

1 WARNINGS
1 ERRORS
Comment 7 errata-xmlrpc 2013-09-05 09:24:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1211.html

Note You need to log in before you can comment on or make changes to this bug.