Bug 997205 - [abrt] valyriatear-0.5.0-4.fc19: exit: Process /usr/bin/valyriatear was killed by signal 11 (SIGSEGV)
[abrt] valyriatear-0.5.0-4.fc19: exit: Process /usr/bin/valyriatear was kille...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: valyriatear (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Erik Schilling
Fedora Extras Quality Assurance
abrt_hash:028161267c3387a50e29be013cf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 19:49 EDT by David Gibson
Modified: 2014-02-21 18:41 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 18:41:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (30.82 KB, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: core_backtrace (6.76 KB, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: dso_list (6.18 KB, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: environ (1.54 KB, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: maps (29.61 KB, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: open_fds (102 bytes, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: proc_pid_status (960 bytes, text/plain)
2013-08-14 19:49 EDT, David Gibson
no flags Details
File: var_log_messages (457 bytes, text/plain)
2013-08-14 19:50 EDT, David Gibson
no flags Details

  None (edit)
Description David Gibson 2013-08-14 19:49:23 EDT
Description of problem:
Seems to SEGV upon exit.

Version-Release number of selected component:
valyriatear-0.5.0-4.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        valyriatear
crash_function: exit
executable:     /usr/bin/valyriatear
kernel:         3.10.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (3 frames)
 #17 exit at exit.c:99
 #18 __libc_start_main at libc-start.c:292
 #19 _start
Comment 1 David Gibson 2013-08-14 19:49:28 EDT
Created attachment 786727 [details]
File: backtrace
Comment 2 David Gibson 2013-08-14 19:49:31 EDT
Created attachment 786728 [details]
File: cgroup
Comment 3 David Gibson 2013-08-14 19:49:35 EDT
Created attachment 786729 [details]
File: core_backtrace
Comment 4 David Gibson 2013-08-14 19:49:39 EDT
Created attachment 786730 [details]
File: dso_list
Comment 5 David Gibson 2013-08-14 19:49:42 EDT
Created attachment 786731 [details]
File: environ
Comment 6 David Gibson 2013-08-14 19:49:46 EDT
Created attachment 786732 [details]
File: limits
Comment 7 David Gibson 2013-08-14 19:49:51 EDT
Created attachment 786733 [details]
File: maps
Comment 8 David Gibson 2013-08-14 19:49:55 EDT
Created attachment 786734 [details]
File: open_fds
Comment 9 David Gibson 2013-08-14 19:49:58 EDT
Created attachment 786735 [details]
File: proc_pid_status
Comment 10 David Gibson 2013-08-14 19:50:01 EDT
Created attachment 786736 [details]
File: var_log_messages
Comment 11 Erik Schilling 2013-08-15 00:55:41 EDT
Forwared to https://github.com/Bertram25/ValyriaTear/issues/212.
Thanks for reporting. I am unable to reproduce it, but maybe the devs now more.

Regards,
Erik
Comment 12 David Gibson 2013-08-15 00:59:11 EDT
I use an unusual window manager (xmonad).  It's possible that has something to do with the triggering conditions.
Comment 13 Erik Schilling 2013-08-15 14:10:02 EDT
If you check the issue I forwarded you can see that the developer think that it is fixed. Can you maybe try to compile the latest development version from there and try it?

Regards,
Erik
Comment 14 David Gibson 2013-08-19 20:40:06 EDT
Yes, I tried the upstream source briefly and it didn't seem to hit the same problem.
Comment 15 Erik Schilling 2014-02-21 18:41:34 EST
I will work on updating the package soon which should also pull in this bugfix(es).

Sorry for the delay.

Note You need to log in before you can comment on or make changes to this bug.