Bug 997230 - RFE: JMX Stats in local vs. clustered modes
RFE: JMX Stats in local vs. clustered modes
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: CR1
: 6.2.1
Assigned To: gsheldon
Martin Gencur
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-14 23:25 EDT by Misha H. Ali
Modified: 2014-04-03 23:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-03 23:56:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-08-14 23:25:13 EDT
Details about the JMX Statistics available in JDGs local mode vs. clustered modes.

Scope: 1-2 topics specifying which statistics are available in local mode only, clustered mode only, or both.

Guide: Admin and Configuration Guide

Source: JBoss DataGrid questions
Comment 3 Martin Gencur 2014-02-03 04:05:01 EST
Hi Misha,
this is the info I was able to gather. Components (MBeans) that are available by default in clustered mode and are not in local mode. For individual components, I don't mention all attributes but only some of them. Not sure we need to mention every single attribute of every component in docs.

LocalTopologyManager (Controls the cache membership and state transfer)
Address: jboss.infinispan:type=CacheManager,name="clustered",component=LocalTopologyManager

attribute - rebalancingEnabled

-----
JGroups Channel:
Address: jboss.infinispan:type=channel,cluster="clustered"

attributes like:
sent_bytes
state
reveived_bytes
timer_threads
cluster_name
address
view
address_uuid

operations like:
resetStats
disconnect
dumpStats
close
connect
-----
JGroups protocols together with their attributes and operations:

Protocols Listed:
FD_ALL (address: jboss.infinispan:type=protocol,cluster="clustered",protocol=FD_ALL)
FD_SOCK
FRAG2
GMS
MERGE2
MFC
NAKACK
PING
RSVP
SABLE
UDP
UFC
UNICAST
------
DistributionManager (Component that handles distribution of content across a cluster):
Address: jboss.infinispan:type=Cache,name="default(dist_sync)",manager="clustered",component=DistributionManager

Operations:
isLocatedLocally(key)
locateKey(key)
isAffectedByRehash(key)
------
RpcManager (Manages all remote calls to remote cache instances in the cluster.):
Address: jboss.infinispan:type=Cache,name="default(dist_sync)",manager="clustered",component=RpcManager

Attributes:
replicationCount
acerageReplicationTime
replicationFailures

Operations:
resetStatistics
------
StateTransferManager (Component that handles state transfer)
Address: jboss.infinispan:type=Cache,name="default(dist_sync)",manager="clustered",component=StateTransferManager

Attributes:
joinComplete
stateTransferInProgress
Comment 4 gsheldon 2014-02-04 01:30:38 EST
Assigning to myself since I forgot to before emailing Martin.

Thanks for your response Martin!
Comment 5 gsheldon 2014-03-06 02:10:48 EST
Hi Martin,

Re: listing all attributes. We have the following Appendix to the Admin Guide which describes Attributes and Operations of MBeans in detail:

https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Data_Grid/6.2/html-single/Administration_and_Configuration_Guide/index.html#appe-JMX_MBeans_in_RedHat__JBoss_Data_Grid

Is this level of detail not required for the components you mention above?

thanks,

Gemma.
Comment 6 Martin Gencur 2014-03-06 03:26:54 EST
Hi Gemma,
you're right, the level of detail should be probably the same. Looking at the Appendix, it seems most of the MBeans are already described well. Some of them just need a note about being available only in clustered mode.

One MBean that is not in the Appendix is LocalTopologyManager. So I'm providing more information. Feel free to rephrase it. 

LocalTopologyManager
--------------------

Class: org.infinispan.topology.LocalTopologyManagerImpl
Description: Controls the cache membership and state transfer

Attributes: 
* rebalancingEnabled 
   type: boolean
   writable: yes
   description: If false, newly started nodes will not join the existing cluster nor the state will be transferred to them. If any of the current cluster members are stopped when rebalancing is disabled, the nodes will leave the cluster         but the state won't be rebalanced among the remaining nodes. This will result in fewer copies than specified by the numOwners attribute until the rebalancing is enabled again.

I'm not sure whether we need to describe also the JGroups Channel and individual JGroups protocols. The JGroups Channel is available only in client-server mode (IMO) and the JGroups protocols might be different (different set of protocols). Maybe you can check with Tristan?

Note You need to log in before you can comment on or make changes to this bug.