Bug 997246 - Could create a domain using a space but fail to change it
Could create a domain using a space but fail to change it
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 01:12 EDT by Tian Feng
Modified: 2015-05-14 21:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:51:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tian Feng 2013-08-15 01:12:59 EDT
Description of problem:
Being able to create a domain using " ", after that failing to change it. It returns "Domain '' not found." error message. Then using another account to create a domain using " ", it shows that "Namespace ' ' is already in use. Please choose another."

Version-Release number of selected component (if applicable):
INT(devenv_3652)

How reproducible:
Always

Steps to Reproduce:
1. go to web console and sign in
2. go to setting page and set the domain as space like " "
3. try to change the domain

Actual results:
Create a domain using " ", and fail to change it, other account can not set its domain as space.

Expected results:
Cannot set domain as a space. And can change the domain name successfully.

Additional info:
Comment 1 Clayton Coleman 2013-08-15 10:29:50 EDT
Fixed in https://github.com/openshift/origin-server/pull/3370
Comment 2 openshift-github-bot 2013-08-16 12:03:15 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/4d0bc395d4f3c38e44572bcc8284990af1f3b1e0
Bug 997246 - Prohibit blank domains

Needed to use allow_nil instead of allow_blank
Comment 3 Tian Feng 2013-08-18 22:34:26 EDT
Test on latest devenv_3671, the problem is solved. So verified the problem. Thanks!
Comment 4 Tian Feng 2013-08-18 22:59:36 EDT
Cannot create a domain with a blank, and also it doesn't need to change a domain from a blank. It returns expected result.

Note You need to log in before you can comment on or make changes to this bug.