Bug 997261 - Fail to snapshot save scalable apps with any kind of database cartridge embedded
Fail to snapshot save scalable apps with any kind of database cartridge embedded
Status: CLOSED DUPLICATE of bug 997234
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 02:01 EDT by congqiyuan
Modified: 2015-05-14 19:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 09:52:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description congqiyuan 2013-08-15 02:01:23 EDT
Description of problem:
Fail to snapshot save scalable apps with postgresql-9.2 or postgresql-8.4 embedded

Version-Release number of selected component (if applicable):
INT(devenv_3652)
devenv_3653

How reproducible:
always

Steps to Reproduce:
1.create a scalable app1
2.embed the app1 with postgresql and add some data to postgresql
3.snapshot save the app

Actual results:
We were unable to snapshot this application due to communication issues with the OpenShift broker.  Please try again later.
500 Internal Server Error
["/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/abstract_response.rb:48:in `return!'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:220:in `process_result'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:169:in `block in transmit'", "/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:746:in `start'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:166:in `transmit'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:60:in `execute'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container.rb:432:in `get_gear_groups'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:87:in `handle_scalable_snapshot'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:47:in `snapshot'", "/usr/bin/gear:295:in `block (2 levels) in <main>'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:62:in `run!'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/delegates.rb:11:in `run!'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/import.rb:10:in `block in <top (required)>'"]

Expected results:
should success without errors

Additional info:
Comment 1 Lei Zhang 2013-08-15 02:26:27 EDT
also failed to snapshot save scalable apps with mysql-5.1 or mongodb-2.2

[lijun@rayzhang Work]$ rhc app start -a  myruby18s
RESULT:
myruby18s started
[lijun@rayzhang Work]$ rhc app show --gear -a  myruby18s
ID                       State   Cartridges           Size  SSH URL
------------------------ ------- -------------------- ----- --------------------------------------------------------------------------
520c6add39ae930adb000006 started ruby-1.8 haproxy-1.4 small 520c6add39ae930adb000006@myruby18s-rayzhang.dev.rhcloud.com
757016670152153161007104 started mongodb-2.2          small 757016670152153161007104@757016670152153161007104-rayzhang.dev.rhcloud.com
[lijun@rayzhang Work]$ rhc snapshot save myruby18s
Pulling down a snapshot to myruby18s.tar.gz...
We were unable to snapshot this application due to communication issues with the OpenShift broker.  Please try again later.
500 Internal Server Error
["/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/abstract_response.rb:48:in `return!'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:220:in `process_result'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:169:in `block in transmit'", "/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:746:in `start'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:166:in `transmit'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:60:in `execute'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container.rb:432:in `get_gear_groups'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:87:in `handle_scalable_snapshot'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:47:in `snapshot'", "/usr/bin/gear:295:in `block (2 levels) in <main>'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:62:in `run!'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/delegates.rb:11:in `run!'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/import.rb:10:in `block in <top (required)>'"]

RESULT:
Success

[lijun@rayzhang Work]$ rhc app show --gear -a myruby18s
ID                       State   Cartridges           Size  SSH URL
------------------------ ------- -------------------- ----- --------------------------------------------------------------------------
520c6add39ae930adb000006 started ruby-1.8 haproxy-1.4 small 520c6add39ae930adb000006@myruby18s-rayzhang.dev.rhcloud.com
462885167749278671568896 started mysql-5.1            small 462885167749278671568896@462885167749278671568896-rayzhang.dev.rhcloud.com
[lijun@rayzhang Work]$ rhc snapshot save  -a myruby18s
Pulling down a snapshot to myruby18s.tar.gz...
We were unable to snapshot this application due to communication issues with the OpenShift broker.  Please try again later.
500 Internal Server Error
["/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/abstract_response.rb:48:in `return!'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:220:in `process_result'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:169:in `block in transmit'", "/opt/rh/ruby193/root/usr/share/ruby/net/http.rb:746:in `start'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:166:in `transmit'", "/opt/rh/ruby193/root/usr/share/gems/gems/rest-client-1.6.1/lib/restclient/request.rb:60:in `execute'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container.rb:432:in `get_gear_groups'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:87:in `handle_scalable_snapshot'", "/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.4/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:47:in `snapshot'", "/usr/bin/gear:295:in `block (2 levels) in <main>'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:62:in `run!'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/delegates.rb:11:in `run!'", "/opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/import.rb:10:in `block in <top (required)>'"]

RESULT:
Success
Comment 2 Clayton Coleman 2013-08-15 09:52:43 EDT
Same root cause as 997234

*** This bug has been marked as a duplicate of bug 997234 ***

Note You need to log in before you can comment on or make changes to this bug.