Bug 997364 - CLI changeset info command with dependencies parameter shows error
CLI changeset info command with dependencies parameter shows error
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity low (vote)
: Unspecified
: --
Assigned To: Justin Sherrill
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 05:45 EDT by Ales Dujicek
Modified: 2014-03-18 13:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Dujicek 2013-08-15 05:45:32 EDT
Description of problem:

CLI command changeset info with --dependencies flag shows error:

> changeset info --org org --name cs1 --dependencies --environment env
undefined method `calc_dependencies' for #<PromotionChangeset:0x0000000827c998>


Version-Release number of selected component (if applicable):
katello-glue-elasticsearch-1.4.3-1.git.185.3c12e3d.el6.noarch
katello-glue-pulp-1.4.3-1.git.185.3c12e3d.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-cli-1.4.3-1.git.7.a387813.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-configure-1.4.4-1.git.2.ce427c5.el6.noarch
katello-glue-candlepin-1.4.3-1.git.185.3c12e3d.el6.noarch
katello-all-1.4.3-1.git.185.3c12e3d.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-cli-common-1.4.3-1.git.7.a387813.el6.noarch
signo-katello-0.0.9-1.el6.noarch
katello-selinux-1.4.4-1.el6.noarch
katello-common-1.4.3-1.git.185.3c12e3d.el6.noarch
pulp-katello-plugins-0.2-1.el6.noarch
katello-1.4.3-1.git.185.3c12e3d.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. changeset create --org org --name cs1 --environment env
2. changeset info --org org --name cs1 --dependencies --environment env --dependencies

Actual results:
undefined method `calc_dependencies' for #<PromotionChangeset:0x00000009e868c8>

Expected results:


Additional info:
Comment 2 Justin Sherrill 2013-09-17 10:44:03 EDT
This option no longer actually has any value since you can no longer add packages to a changeset (and so a changeset can no longer have dependencies).

Removing that option here:

https://github.com/Katello/katello-cli/pull/89
Comment 3 Mike McCune 2014-03-18 13:37:41 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.