Bug 997374 - missing --new_namespace option in oo-admin-ctl-domain help page
missing --new_namespace option in oo-admin-ctl-domain help page
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 06:40 EDT by Meng Bo
Modified: 2015-05-14 20:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-26 14:07:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-08-15 06:40:16 EDT
Description of problem:
When trying to update domain name with oo-admin-ctl-domain command, the help does not tell user need using --new_namespace option, and this option is required when updating domain name.

Version-Release number of selected component (if applicable):
devenv_3654

How reproducible:
always

Steps to Reproduce:
1.Use oo-admin-ctl-domain to update namespace
2.Check the help for the method
3.

Actual results:
# oo-admin-ctl-domain -h 
== Synopsis

oo-admin-ctl-domain: Manage user domains

== Usage

oo-admin-ctl-domain OPTIONS

Options:
-l|--login <login_name>
    Login with OpenShift access (required)
-p|--provider <provider_name>
    Source of the login (optional)
-n|--namespace <Namespace>
    Namespace for application(s) (alphanumeric - max 16 chars) (required)
-c|--command (create|update|delete|info|env_add|env_del)
-s|--ssh_key <ssh key>
    User's SSH key
-t|--key_type <ssh key type>
    User's SSH key type (ssh-rsa|ssh-dss|ssh-rsa-cert-v01@openssh.com|ssh-dss-cert-v01@openssh.com|ssh-rsa-cert-v00@openssh.com|ssh-dss-cert-v00@openssh.com)
-k|--key_name <ssh key name>
    User's SSH key name
-e|--env_name <env var name>
-v|--env_value <env var value>
-h|--help:
    Show Usage info


Expected results:
Show include the --new_namespace option.


Additional info:    
["--new_namespace"         , GetoptLong::REQUIRED_ARGUMENT],

new_namespace = args["--new_namespace"]

The option can be found in the script.
Comment 1 Clayton Coleman 2013-08-15 10:42:12 EDT
Fixed in https://github.com/openshift/origin-server/pull/3371
Comment 2 openshift-github-bot 2013-08-16 13:09:05 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/224af54066904e7ea0d9c0a4f083de604fabff06
Bug 997374 - Fix man page for oo-admin-ctl-domain

Add --new_namespace
Comment 3 Meng Bo 2013-08-18 23:01:02 EDT
Checked on devenv_3671, the man page of the command has been fixed.

But the help page still missing the option.



# oo-admin-ctl-domain --help
== Synopsis

oo-admin-ctl-domain: Manage user domains

== Usage

oo-admin-ctl-domain OPTIONS

Options:
-l|--login <login_name>
    Login with OpenShift access (required)
-p|--provider <provider_name>
    Source of the login (optional)
-n|--namespace <Namespace>
    Namespace for application(s) (alphanumeric - max 16 chars) (required)
-c|--command (create|update|delete|info|env_add|env_del)
-s|--ssh_key <ssh key>
    User's SSH key
-t|--key_type <ssh key type>
    User's SSH key type (ssh-rsa|ssh-dss|ssh-rsa-cert-v01@openssh.com|ssh-dss-cert-v01@openssh.com|ssh-rsa-cert-v00@openssh.com|ssh-dss-cert-v00@openssh.com)
-k|--key_name <ssh key name>
    User's SSH key name
-e|--env_name <env var name>
-v|--env_value <env var value>
-h|--help:
    Show Usage info
Comment 4 Clayton Coleman 2013-09-25 16:44:06 EDT
Fixed in commit 13c0327 in membership branch.
Comment 5 Liang Xia 2013-09-26 06:46:52 EDT
Checked on devenv_3832,
 Help page not fixed.
 Man page show "--new_namespace name_space The  new namespace value when renaming a domain, alphanumeric, 16 chars max. Required for --command update."

Also checked on fork_ami_origin_ui_72_membership_863,
 Help page fixed. show "--new_namespace <Namespace> New namespace for application(s) (alphanumeric - max 16 chars) (required for --comand update)"
 Man page show "--new_namespace name_space The  new namespace value when renaming a domain, alphanumeric, 16 chars max. Optional for --command update."

So the fix is not perfect.
Needs to update "Optional for --command update." to "Required for --command update."
Comment 6 openshift-github-bot 2013-09-26 20:33:19 EDT
Commits pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/1a561a4e32d7e67d2c470d9a086aeb54140b4095
Bug 997374 - Update help for oo-admin-ctl-domain

Also add --allowed-gear-sizes support to oo-admin-ctl-domain

https://github.com/openshift/origin-server/commit/13c0327c50cdc9d89c007b25be603f4d78decbfe
Bug 997374 - Add new_namespace to oo-admin-ctl-domain
Comment 7 Dan McPherson 2014-02-07 19:31:05 EST
It looks like the change hadn't landed yet when last tested.  Please retest.
Comment 8 Meng Bo 2014-02-11 01:28:50 EST
Checked on devenv_4357.

There is a typo in the help.

   --new_namespace <Namespace>
    New namespace for application(s) (alphanumeric - max 16 chars) (required
      for --comand update)
          ^^^^^^^^
Comment 9 Dan McPherson 2014-02-11 11:29:09 EST
https://github.com/openshift/origin-server/pull/4727
Comment 11 Meng Bo 2014-02-13 01:47:37 EST
Issue fixed on devenv_4369,

# oo-admin-ctl-domain 
== Synopsis

oo-admin-ctl-domain: Manage user domains

== Usage

oo-admin-ctl-domain OPTIONS

Options:
-l|--login <login_name>
    Login with OpenShift access (required)
-p|--provider <provider_name>
    Source of the login (optional)
-n|--namespace <Namespace>
    Namespace for application(s) (alphanumeric - max 16 chars) (required)
   --new_namespace <Namespace>
    New namespace for application(s) (alphanumeric - max 16 chars) (required
      for --command update)
-c|--command (create|update|delete|info|env_add|env_del)
-s|--ssh_key <ssh key>
    User's SSH key
-t|--key_type <ssh key type>
    User's SSH key type (ssh-rsa|ssh-dss|ssh-rsa-cert-v01@openssh.com|ssh-dss-cert-v01@openssh.com|ssh-rsa-cert-v00@openssh.com|ssh-dss-cert-v00@openssh.com|krb5-principal)
-k|--key_name <ssh key name>
    User's SSH key name
-e|--env_name <env var name>
-v|--env_value <env var value>
-h|--help:
    Show Usage info

Note You need to log in before you can comment on or make changes to this bug.