This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 997412 - Unable to create new vm when the storage pool is unitialized
Unable to create new vm when the storage pool is unitialized
Status: CLOSED WONTFIX
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Linux
unspecified Severity low
: ---
: 3.4.0
Assigned To: Nobody's working on this, feel free to take it
bugs@ovirt.org
virt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 09:07 EDT by Nir Soffer
Modified: 2014-02-14 09:20 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-14 09:20:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log while reproducing this bug (73.25 KB, text/x-log)
2013-08-15 09:07 EDT, Nir Soffer
no flags Details

  None (edit)
Description Nir Soffer 2013-08-15 09:07:00 EDT
Created attachment 786932 [details]
Log while reproducing this bug

Description of problem:
Unable to create new vm when the storage pool is unitialized

Version-Release number of selected component (if applicable):
ovirt-engine commit 7af2eec6799e

How reproducible:
Always

Steps to Reproduce:
1. Build and install
2. Add a host
3. Add a vm

Actual results:
On the "New virtual machine" dialog, both "Cluster" and "Based on template" popup menus are empty, but required so the vm can't be created.

Expected results:
Both menus should show normal content.

Additional info:

Workaround:
Add a storage domain, then create the vm.
Comment 1 Itamar Heim 2013-08-17 18:14:28 EDT
this sounds like by design in current system to me
Comment 2 Frantisek Kobzik 2013-09-10 09:14:51 EDT
But there is an inconsistency between rest api and the ui. rest api does allow creating vm without active storage domain and it can be actually quite useful for some situations (running a diskless vm from the network). what do you think?
Comment 3 Itamar Heim 2013-09-10 13:15:46 EDT
(In reply to Frantisek Kobzik from comment #2)
> But there is an inconsistency between rest api and the ui. rest api does
> allow creating vm without active storage domain and it can be actually quite
> useful for some situations (running a diskless vm from the network). what do
> you think?

that i'm not sure how/when that's would be useful...
Comment 4 Itamar Heim 2014-01-12 03:41:25 EST
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.
Comment 5 Michal Skrivanek 2014-02-14 09:20:22 EST
it's fine to have some additional functionality via REST. In GUI the use case doesn't look interesting enough

Note You need to log in before you can comment on or make changes to this bug.