Bug 997565 - Watchdog model ib700 not supported
Watchdog model ib700 not supported
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
All Linux
medium Severity medium
: ---
: 3.3.0
Assigned To: Laszlo Hornyak
Lukas Svaty
http://www.ovirt.org/Features/Watchdo...
sla
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 11:46 EDT by Lukas Svaty
Modified: 2016-02-10 15:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 11:00:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (263.60 KB, text/x-log)
2013-08-30 13:22 EDT, Lukas Svaty
no flags Details
engine.log (6.65 KB, text/x-log)
2013-08-30 13:23 EDT, Lukas Svaty
no flags Details

  None (edit)
Description Lukas Svaty 2013-08-15 11:46:43 EDT
Description of problem:
When adding watchdog card of model ib700. Watchdog card doesn't exist on VM.

`lspci | grep -i watchdog` returns nothing

Version-Release number of selected component (if applicable):
is10

How reproducible:
100%

Steps to Reproduce:
1. Add VM with watchdog card
2. Set watchdog model to ib7000
3. Install linux OS
4. see `lspci | grep -i watchdog`

Actual results:
Watchdog card ib700 is not supported yet in is10
Comment 1 Doron Fediuck 2013-08-21 06:53:14 EDT
Lukas,
can you provide us the relevant vdsm log please?
Comment 2 Laszlo Hornyak 2013-08-28 10:11:11 EDT
ib700 is not a PCI device, you will not be able to detect it with lspci
Comment 3 Laszlo Hornyak 2013-08-30 09:38:13 EDT
Lukas, I just noticed that the ib700wdt module is not loaded by default in fedora. Please check that in the guest VM the ib700wdt is loaded, otherwise even though the watchdog daemon is started, the watchdog is not armed, therefore the action will not be triggered.

After enabling the kernel module in guest, the ib700 device worked just fine for me.
Comment 4 Lukas Svaty 2013-08-30 13:09:42 EDT
the problem was that the kernel module was not loaded (in fedora nor RHEL)

`modprobe ib700wdt`

did the work...

however after setting action to dump/reset and installing watchdog card ib700 properly, when I tried to trigger watchdog by killing the watchdog process (killall -9 watchdog / kill -9 `pgrep watchdog`), watchdog action was not triggered (neither after crashing the kernel)

when I checked the edit option tab of Vm in High Availability watchdog model as well as watchdog action what again set to blank

/api/vms/`vm-id`/watchdogs changed from 

<watchdogs>
  <watchdog href="/api/vms/07fe5216-18fd-4869-844b-cf43a1377220/watchdogs/00000000-0000-0000-0000-000000000000" id="00000000-0000-0000-0000-000000000000">
    <vm href="/api/vms/07fe5216-18fd-4869-844b-cf43a1377220" id="07fe5216-18fd-4869-844b-cf43a1377220"/>
    <model>ib700</model>
    <action>reset</action>
  </watchdog>
</watchdogs>

to <watchdogs/> right after the VM is started
Comment 5 Lukas Svaty 2013-08-30 13:22:27 EDT
Created attachment 792262 [details]
vdsm.log
Comment 6 Lukas Svaty 2013-08-30 13:23:04 EDT
Created attachment 792263 [details]
engine.log
Comment 7 Laszlo Hornyak 2013-09-03 11:00:08 EDT
the dump part is in another bug
Comment 8 Laszlo Hornyak 2013-09-09 05:06:19 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=1004400 - the libvirt related bug for dump

Note You need to log in before you can comment on or make changes to this bug.