Bug 997567 - misleading help text for adding alias.
misleading help text for adding alias.
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
: UpcomingRelease
Depends On:
Blocks: 997320
  Show dependency treegraph
 
Reported: 2013-08-15 11:49 EDT by Brenton Leanhardt
Modified: 2015-05-14 21:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 997320
Environment:
Last Closed: 2013-08-29 08:51:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-08-15 11:49:43 EDT
I think the idea here is simply to make the error text more understandable.  Users need to know they can't create aliases for anything in the $CLOUD_DOMAIN.

+++ This bug was initially created as a clone of Bug #997320 +++

Description of problem:
  When trying to enter an alias from the UI for my app, the help text is misleading and incorrect

Enter your custom domain name. e.g. www.example.com or something.example.com

  If I were to put test.example.com it will display the error.  "Invalid Server Alias 'ppp.example.com' specified".  From the code, it looks like if the instance's hostname has example.com as part of the domain name it will be flagged as error, therefore the help text in the UI is incorrect.

Version-Release number of selected component (if applicable):
current

How reproducible:
always.

Steps to Reproduce:
1.  In the UI's add alias text box, enter something like test.example.com
2.
3.

Actual results:
failed with the error similar to Invalid Server Alias 'ppp.example.com' specified"

Expected results:
success.

Additional info:

--- Additional comment from Brenton Leanhardt on 2013-08-15 10:36:53 EDT ---

Does this happen in Online if you choose an rhcloud.com domain for your alias?  If so we should work on the bug there.

--- Additional comment from Peter Ruan on 2013-08-15 11:43:56 EDT ---

Yes, if I were to put test.rhcloud.com as my alias it throws the same error.  I think it's the regular expression that's flagging it.
Comment 1 Clayton Coleman 2013-08-20 11:41:32 EDT
Should explain blacklisted domains to users via error messages and change help.
Comment 2 Clayton Coleman 2013-08-21 13:46:24 EDT
Made slightly less vague in https://github.com/openshift/origin-server/pull/3451
Comment 3 openshift-github-bot 2013-08-21 16:29:01 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/08a37d25076ad0221c8bc3a4305c0a20c249375a
Bug 997567 - The alias error message is too vague
Comment 4 Tian Feng 2013-08-22 03:02:58 EDT
Test on devenv_3683, and when I add an alias as "example.dev.rhcloud.com", it would return "The specified alias is not allowed: 'example.dev.rhcloud.com'" as expected. So verified it, thanks!

Note You need to log in before you can comment on or make changes to this bug.