Bug 997597 - DT Gov UI fails to load deployments (to be displayed in UI)
DT Gov UI fails to load deployments (to be displayed in UI)
Status: CLOSED DUPLICATE of bug 978791
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER2
: ---
Assigned To: Len DiMaggio
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 13:46 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 10:03:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log (109.54 KB, text/plain)
2013-08-15 13:52 EDT, Len DiMaggio
no flags Details
Screenshot (9.04 KB, image/png)
2013-08-15 13:53 EDT, Len DiMaggio
no flags Details
Screenshot (208.72 KB, image/png)
2013-08-15 13:54 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-08-15 13:46:56 EDT
Description of problem:

See the attached screenshots

Version-Release number of selected component (if applicable):
August 15 ER1 respin

How reproducible:
100%

Steps to Reproduce:
1. Access the DTGov UI here: http://localhost:8080/dtgov-ui/
2. Select the "DT Governance" tab
3. Select Deployment Lifecycle
4. Observe the error

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-08-15 13:50:19 EDT
This exception is written to the server log:





13:46:17,909 ERROR [stderr] (http-/127.0.0.1:8080-4) org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
13:46:17,915 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.io.AbstractRPCMethodCallback.invokeMethodFromMessage(AbstractRPCMethodCallback.java:52)
13:46:17,916 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.io.ValueReplyRPCEndpointCallback.callback(ValueReplyRPCEndpointCallback.java:22)
13:46:17,916 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.io.RemoteServiceCallback.callback(RemoteServiceCallback.java:54)
13:46:17,917 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.cdi.server.CDIExtensionPoints$3.callback(CDIExtensionPoints.java:516)
13:46:17,917 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.DeliveryPlan.deliver(DeliveryPlan.java:51)
13:46:17,918 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.ServerMessageBusImpl.sendGlobal(ServerMessageBusImpl.java:294)
13:46:17,918 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.SimpleDispatcher.dispatchGlobal(SimpleDispatcher.java:46)
13:46:17,919 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:92)
13:46:17,919 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:109)
13:46:17,919 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.servlet.DefaultBlockingServlet.doPost(DefaultBlockingServlet.java:139)
13:46:17,920 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
13:46:17,920 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
13:46:17,920 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)
13:46:17,920 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
13:46:17,920 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
13:46:17,920 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)
13:46:17,920 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:481)
13:46:17,921 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
13:46:17,921 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
13:46:17,921 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
13:46:17,921 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
13:46:17,921 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
13:46:17,921 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
13:46:17,922 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653)
13:46:17,922 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
13:46:17,922 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at java.lang.Thread.run(Thread.java:722)
13:46:17,922 ERROR [stderr] (http-/127.0.0.1:8080-4) Caused by: org.overlord.dtgov.ui.client.shared.exceptions.DtgovUiException: org.overlord.sramp.atom.err.SrampAtomException: Invalid classified-by (it is either an invalid URI or it is not defined by an S-RAMP ontology): http://www.jboss.org/overlord/deployment-status.owl#Lifecycle
13:46:17,922 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.dtgov.ui.server.services.DeploymentsService.search(DeploymentsService.java:118)
13:46:17,923 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
13:46:17,936 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
13:46:17,937 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
13:46:17,937 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at java.lang.reflect.Method.invoke(Method.java:601)
13:46:17,937 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.errai.bus.server.io.AbstractRPCMethodCallback.invokeMethodFromMessage(AbstractRPCMethodCallback.java:43)
13:46:17,937 ERROR [stderr] (http-/127.0.0.1:8080-4) 	... 25 more
13:46:17,937 ERROR [stderr] (http-/127.0.0.1:8080-4) Caused by: org.overlord.sramp.atom.err.SrampAtomException: Invalid classified-by (it is either an invalid URI or it is not defined by an S-RAMP ontology): http://www.jboss.org/overlord/deployment-status.owl#Lifecycle
13:46:17,937 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.JCRPersistence.resolve(JCRPersistence.java:620)
13:46:17,938 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.JCRPersistence.resolveAll(JCRPersistence.java:645)
13:46:17,938 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.resolveArgumentsToClassifications(SrampToJcrSql2QueryVisitor.java:409)
13:46:17,938 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:321)
13:46:17,938 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.FunctionCall.accept(FunctionCall.java:77)
13:46:17,938 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:490)
13:46:17,938 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.SubartifactSet.accept(SubartifactSet.java:106)
13:46:17,939 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:261)
13:46:17,939 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.EqualityExpr.accept(EqualityExpr.java:82)
13:46:17,939 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:422)
13:46:17,939 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.OrExpr.accept(OrExpr.java:43)
13:46:17,939 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:228)
13:46:17,939 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.AndExpr.accept(AndExpr.java:43)
13:46:17,940 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:283)
13:46:17,940 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.Expr.accept(Expr.java:58)
13:46:17,940 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:435)
13:46:17,940 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.Predicate.accept(Predicate.java:57)
13:46:17,940 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:151)
13:46:17,940 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.common.query.xpath.ast.Query.accept(Query.java:86)
13:46:17,941 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.JCRSrampQuery.createSql2Query(JCRSrampQuery.java:134)
13:46:17,941 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.jcr.query.JCRSrampQuery.executeQuery(JCRSrampQuery.java:88)
13:46:17,941 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.repository.query.AbstractSrampQueryImpl.executeQuery(AbstractSrampQueryImpl.java:175)
13:46:17,941 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.server.atom.services.AbstractFeedResource.createArtifactFeed(AbstractFeedResource.java:83)
13:46:17,942 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.server.atom.services.QueryResource.query(QueryResource.java:157)
13:46:17,942 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.overlord.sramp.server.atom.services.QueryResource.queryFromPost(QueryResource.java:123)
13:46:17,942 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
13:46:17,942 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at java.lang.reflect.Method.invoke(Method.java:601)
13:46:17,942 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:167)
13:46:17,943 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:269)
13:46:17,943 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:227)
13:46:17,943 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:216)
13:46:17,943 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:542)
13:46:17,944 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:524)
13:46:17,944 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:126)
13:46:17,944 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)
13:46:17,944 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)
13:46:17,944 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)
13:46:17,945 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
13:46:17,945 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)
13:46:17,945 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
13:46:17,945 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
13:46:17,945 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)
13:46:17,945 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:481)
13:46:17,946 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
13:46:17,946 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
13:46:17,946 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
13:46:17,946 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
13:46:17,946 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
13:46:17,946 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
13:46:17,947 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at Http11ConnectionHandler.process(Http11Protocol.java:653)
13:46:17,947 ERROR [stderr] (http-/127.0.0.1:8080-4) 	at Worker.run(JIoEndpoint.java:920)
13:46:17,947 ERROR [stderr] (http-/127.0.0.1:8080-4) 	... 1 more
13:46:17,947 ERROR [stderr] (http-/127.0.0.1:8080-4) *** Message delivery failure ***
13:46:17,947 ERROR [stderr] (http-/127.0.0.1:8080-4) Bus: org.jboss.errai.bus.server.ServerMessageBusImpl@73203729
13:46:17,947 ERROR [stderr] (http-/127.0.0.1:8080-4) Message: CommandType=search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.lang.String:int:, ErrorTo=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC.search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.lang.String:int::5:Errors:RPC, ReplyTo=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC.search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.lang.String:int::5:RespondTo:RPC, ToSubject=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC, MethodParms=[org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean@1b4d89f, , 1]
13:46:17,947 ERROR [stderr] (http-/127.0.0.1:8080-4) errorMessage: Error calling remote service: org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC
13:46:17,948 ERROR [stderr] (http-/127.0.0.1:8080-4) exception: org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
13:46:17,948 ERROR [stderr] (http-/127.0.0.1:8080-4) disconnect: false
Comment 2 Len DiMaggio 2013-08-15 13:52:22 EDT
Created attachment 787016 [details]
Server log
Comment 3 Len DiMaggio 2013-08-15 13:53:35 EDT
Created attachment 787017 [details]
Screenshot
Comment 4 Len DiMaggio 2013-08-15 13:54:25 EDT
Created attachment 787018 [details]
Screenshot
Comment 5 Eric Wittmann 2013-08-16 07:31:12 EDT
The s-ramp repository has not been seeded with required dtgov seed data.  In particular, the Deployment Lifecycle ontology has not been added.  The UI attempts to perform a query using a classifier defined in an ontology that we ship with dtgov.  The name of the seed data file is "deployment-status.owl" and it is an ontology with a base URL of:

http://www.jboss.org/overlord/deployment-status.owl

In the community version of dtgov, there is an ant script that assists with the seeding of this data.

Note: there is additional seed data in the form of a KIE (jbpm) jar package, which must also be added to the s-ramp repository.  This kie jar must be uploaded into s-ramp using maven.
Comment 6 Kurt Stam 2013-08-20 11:05:29 EDT
So to be clear this is 'pilot error' and see http://docs.jboss.org/overlord/dtgov/1.0.0.Final/html/_getting_started.html#_download_installation_and_configuration

on how to upload the seed data, specifically:

# Start JBoss (target/jboss-eap-6.1/bin/standalone.sh) - wait for startup to complete
ant seed
cd data
mvn package
Comment 7 Eric Wittmann 2013-08-26 10:36:14 EDT
Assigning back to Len for his review (based on previous comments).  It's possible that the product does not include a mechanism for seeding this data into s-ramp.  If that's true, perhaps this BZ should get re-assigned to someone on the product team.

I'd be happy to help with proper configuration of the product.
Comment 9 Len DiMaggio 2013-08-27 10:03:04 EDT
Closing as duplicate of:  978791

*** This bug has been marked as a duplicate of bug 978791 ***

Note You need to log in before you can comment on or make changes to this bug.