Bug 997603 - Not possible to perform new deployments in ER1 DT Gov - java.io.IOException
Not possible to perform new deployments in ER1 DT Gov - java.io.IOException
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER1
: ---
Assigned To: Len DiMaggio
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 14:10 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 22:06:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (7.76 KB, image/png)
2013-08-15 14:13 EDT, Len DiMaggio
no flags Details
Screenshot (200.47 KB, image/png)
2013-08-15 14:14 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-08-15 14:10:36 EDT
Description of problem:

Attempting to deploy a .war or .jar results in an error such as:

Error Adding Deployment
java.io.IOException: Failed to create directory: 
/tmp/jsrampNNNNNNNNNNNNN/.work/META-INF

See attached screenshots.

Version-Release number of selected component (if applicable):
ER1 - August 15 respin

How reproducible:
100%

Steps to Reproduce:
1. Access the DTGov UI here: http://localhost:8080/dtgov-ui/
2. Select the "DT Governance" tab
3. Select Deployment Lifecycle
4. Select Add Deployment
5. Select a .jar or .war
6. Observe exception

Actual results:


Expected results:


Additional info:
Comment 2 Len DiMaggio 2013-08-15 14:13:19 EDT
Nothing is written to the server log when this error occurs.
Comment 3 Len DiMaggio 2013-08-15 14:13:50 EDT
Created attachment 787022 [details]
Screenshot
Comment 4 Len DiMaggio 2013-08-15 14:14:25 EDT
Created attachment 787023 [details]
Screenshot
Comment 5 Eric Wittmann 2013-08-16 07:38:22 EDT
Sounds like something went wrong when unpacking the jar/war for analysis.  I've done this multiple times without error, so it's either an environment issue or something about the particular jar/war being added.

Can you attach an example jar/war that always fails?
Comment 6 Kurt Stam 2013-08-20 13:40:48 EDT
Just to reiterate: this "works on my desk", so like Eric is saying maybe the jar or war you are uploading trips up an issue somewhere else. Can you please attach it so we can reproduce?
Comment 7 Eric Wittmann 2013-08-26 10:16:06 EDT
Assigning to Len so he can attach the WAR/JAR file(s) he used for testing.
Comment 8 Len DiMaggio 2013-09-06 12:46:07 EDT
In ER2, the following exception is raised at the point when the user presses the "Deployments" button here:   http://localhost:8080/dtgov-ui/



12:41:27,010 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Deploying javax.ws.rs.core.Application: class org.overlord.sramp.server.atom.services.SRAMPApplication
12:41:27,012 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.FeedResource from Application javax.ws.rs.core.Application
12:41:27,012 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.BatchResource from Application javax.ws.rs.core.Application
12:41:27,012 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.AuditResource from Application javax.ws.rs.core.Application
12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.brms.BrmsResource from Application javax.ws.rs.core.Application
12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.ServiceDocumentResource from Application javax.ws.rs.core.Application
12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.ArtifactResource from Application javax.ws.rs.core.Application
12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.QueryResource from Application javax.ws.rs.core.Application
12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment] (http-/127.0.0.1:8080-7) Adding singleton resource org.overlord.sramp.server.atom.services.OntologyResource from Application javax.ws.rs.core.Application
12:41:27,848 INFO  [org.overlord.sramp.repository.jcr.JCRRepositoryFactory] (http-/127.0.0.1:8080-8) Found JCR Provider class org.overlord.sramp.repository.jcr.modeshape.ModeshapeRepository
12:41:27,850 INFO  [org.overlord.sramp.repository.jcr.modeshape.ModeshapeRepository] (http-/127.0.0.1:8080-8) Connecting to ModeShape Service jcr/sramp
12:41:27,975 INFO  [org.infinispan.factories.GlobalComponentRegistry] (http-/127.0.0.1:8080-8) ISPN000128: Infinispan version: Infinispan 'Delirium' 5.2.6.Final
12:41:28,378 INFO  [org.infinispan.jmx.CacheJmxRegistration] (http-/127.0.0.1:8080-8) ISPN000031: MBeans were successfully registered to the platform MBean server.
12:41:28,380 INFO  [org.jboss.as.clustering.infinispan] (http-/127.0.0.1:8080-8) JBAS010281: Started sramp cache from modeshape container
12:41:28,910 INFO  [org.infinispan.jmx.CacheJmxRegistration] (http-/127.0.0.1:8080-8) ISPN000031: MBeans were successfully registered to the platform MBean server.
12:41:28,911 INFO  [org.jboss.as.clustering.infinispan] (http-/127.0.0.1:8080-8) JBAS010281: Started sramp/system cache from modeshape container
12:41:30,636 WARN  [org.modeshape.jcr.RepositoryConfiguration] (http-/127.0.0.1:8080-8) The field name is not present on org.modeshape.jcr.security.ServletProvider or any of its super types
12:41:30,744 INFO  [org.hibernate.search.Version] (http-/127.0.0.1:8080-8) HSEARCH000034: Hibernate Search 4.2.0.Final-redhat-4
12:41:31,228 INFO  [org.infinispan.jmx.CacheJmxRegistration] (http-/127.0.0.1:8080-8) ISPN000031: MBeans were successfully registered to the platform MBean server.
12:41:31,229 INFO  [org.jboss.as.clustering.infinispan] (http-/127.0.0.1:8080-8) JBAS010281: Started sramp/default cache from modeshape container
12:41:38,778 ERROR [stderr] (http-/127.0.0.1:8080-2) org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
12:41:38,779 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.io.AbstractRPCMethodCallback.invokeMethodFromMessage(AbstractRPCMethodCallback.java:52)
12:41:38,779 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.io.ValueReplyRPCEndpointCallback.callback(ValueReplyRPCEndpointCallback.java:22)
12:41:38,780 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.io.RemoteServiceCallback.callback(RemoteServiceCallback.java:54)
12:41:38,780 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.cdi.server.CDIExtensionPoints$3.callback(CDIExtensionPoints.java:516)
12:41:38,780 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.DeliveryPlan.deliver(DeliveryPlan.java:51)
12:41:38,781 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.ServerMessageBusImpl.sendGlobal(ServerMessageBusImpl.java:294)
12:41:38,781 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.SimpleDispatcher.dispatchGlobal(SimpleDispatcher.java:46)
12:41:38,782 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:92)
12:41:38,782 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.java:109)
12:41:38,782 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.servlet.DefaultBlockingServlet.doPost(DefaultBlockingServlet.java:139)
12:41:38,783 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
12:41:38,783 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
12:41:38,784 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)
12:41:38,784 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
12:41:38,784 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.dtgov.ui.server.filters.LocaleFilter.doFilter(LocaleFilter.java:63)
12:41:38,785 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246)
12:41:38,785 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
12:41:38,785 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)
12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:481)
12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:653)
12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at java.lang.Thread.run(Thread.java:724)
12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) Caused by: org.overlord.dtgov.ui.client.shared.exceptions.DtgovUiException: org.overlord.sramp.atom.err.SrampAtomException: Invalid classified-by (it is either an invalid URI or it is not defined by an S-RAMP ontology): http://www.jboss.org/overlord/deployment-status.owl#Lifecycle
12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.dtgov.ui.server.services.DeploymentsService.search(DeploymentsService.java:119)
12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at java.lang.reflect.Method.invoke(Method.java:606)
12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.errai.bus.server.io.AbstractRPCMethodCallback.invokeMethodFromMessage(AbstractRPCMethodCallback.java:43)
12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	... 28 more
12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) Caused by: org.overlord.sramp.atom.err.SrampAtomException: Invalid classified-by (it is either an invalid URI or it is not defined by an S-RAMP ontology): http://www.jboss.org/overlord/deployment-status.owl#Lifecycle
12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.JCRPersistence.resolve(JCRPersistence.java:621)
12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.JCRPersistence.resolveAll(JCRPersistence.java:646)
12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.resolveArgumentsToClassifications(SrampToJcrSql2QueryVisitor.java:409)
12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:322)
12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.FunctionCall.accept(FunctionCall.java:77)
12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:490)
12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.SubartifactSet.accept(SubartifactSet.java:106)
12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:262)
12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.EqualityExpr.accept(EqualityExpr.java:82)
12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:422)
12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.OrExpr.accept(OrExpr.java:43)
12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:229)
12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.AndExpr.accept(AndExpr.java:43)
12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:284)
12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.Expr.accept(Expr.java:58)
12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:435)
12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.Predicate.accept(Predicate.java:57)
12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.visit(SrampToJcrSql2QueryVisitor.java:152)
12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.common.query.xpath.ast.Query.accept(Query.java:86)
12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.JCRSrampQuery.createSql2Query(JCRSrampQuery.java:135)
12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.jcr.query.JCRSrampQuery.executeQuery(JCRSrampQuery.java:89)
12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.repository.query.AbstractSrampQueryImpl.executeQuery(AbstractSrampQueryImpl.java:176)
12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.server.atom.services.AbstractFeedResource.createArtifactFeed(AbstractFeedResource.java:84)
12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.server.atom.services.QueryResource.query(QueryResource.java:158)
12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.server.atom.services.QueryResource.queryFromPost(QueryResource.java:124)
12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at java.lang.reflect.Method.invoke(Method.java:606)
12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:167)
12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:269)
12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:227)
12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:216)
12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:542)
12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:524)
12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:126)
12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)
12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)
12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)
12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)
12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.overlord.sramp.server.filters.LocaleFilter.doFilter(LocaleFilter.java:59)
12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:246)
12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)
12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:481)
12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at Http11ConnectionHandler.process(Http11Protocol.java:653)
12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at Worker.run(JIoEndpoint.java:920)
12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	... 1 more
12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) *** Message delivery failure ***
12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) Bus: org.jboss.errai.bus.server.ServerMessageBusImpl@43b40ca0
12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) Message: CommandType=search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.lang.String:int:, ErrorTo=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC.search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.lang.String:int::1:Errors:RPC, ReplyTo=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC.search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.lang.String:int::1:RespondTo:RPC, ToSubject=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC, MethodParms=[org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean@1b4d89f, , 1]
12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) errorMessage: Error calling remote service: org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC
12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) exception: org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking endpoint
12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) disconnect: false
Comment 9 Stefan Bunciak 2013-09-09 07:37:14 EDT
This occurs due to missing dtgov seed data, specifically the deployment-ontology.owl and can be fixed by executing dtgov-sramp-repo-seed-cli-commands.txt manually. 

(In reply to Len DiMaggio from comment #8)
> In ER2, the following exception is raised at the point when the user presses
> the "Deployments" button here:   http://localhost:8080/dtgov-ui/
> 
> 
> 
> 12:41:27,010 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Deploying javax.ws.rs.core.Application: class
> org.overlord.sramp.server.atom.services.SRAMPApplication
> 12:41:27,012 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.FeedResource from Application
> javax.ws.rs.core.Application
> 12:41:27,012 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.BatchResource from Application
> javax.ws.rs.core.Application
> 12:41:27,012 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.AuditResource from Application
> javax.ws.rs.core.Application
> 12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.brms.BrmsResource from Application
> javax.ws.rs.core.Application
> 12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.ServiceDocumentResource from
> Application javax.ws.rs.core.Application
> 12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.ArtifactResource from Application
> javax.ws.rs.core.Application
> 12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.QueryResource from Application
> javax.ws.rs.core.Application
> 12:41:27,013 INFO  [org.jboss.resteasy.spi.ResteasyDeployment]
> (http-/127.0.0.1:8080-7) Adding singleton resource
> org.overlord.sramp.server.atom.services.OntologyResource from Application
> javax.ws.rs.core.Application
> 12:41:27,848 INFO  [org.overlord.sramp.repository.jcr.JCRRepositoryFactory]
> (http-/127.0.0.1:8080-8) Found JCR Provider class
> org.overlord.sramp.repository.jcr.modeshape.ModeshapeRepository
> 12:41:27,850 INFO 
> [org.overlord.sramp.repository.jcr.modeshape.ModeshapeRepository]
> (http-/127.0.0.1:8080-8) Connecting to ModeShape Service jcr/sramp
> 12:41:27,975 INFO  [org.infinispan.factories.GlobalComponentRegistry]
> (http-/127.0.0.1:8080-8) ISPN000128: Infinispan version: Infinispan
> 'Delirium' 5.2.6.Final
> 12:41:28,378 INFO  [org.infinispan.jmx.CacheJmxRegistration]
> (http-/127.0.0.1:8080-8) ISPN000031: MBeans were successfully registered to
> the platform MBean server.
> 12:41:28,380 INFO  [org.jboss.as.clustering.infinispan]
> (http-/127.0.0.1:8080-8) JBAS010281: Started sramp cache from modeshape
> container
> 12:41:28,910 INFO  [org.infinispan.jmx.CacheJmxRegistration]
> (http-/127.0.0.1:8080-8) ISPN000031: MBeans were successfully registered to
> the platform MBean server.
> 12:41:28,911 INFO  [org.jboss.as.clustering.infinispan]
> (http-/127.0.0.1:8080-8) JBAS010281: Started sramp/system cache from
> modeshape container
> 12:41:30,636 WARN  [org.modeshape.jcr.RepositoryConfiguration]
> (http-/127.0.0.1:8080-8) The field name is not present on
> org.modeshape.jcr.security.ServletProvider or any of its super types
> 12:41:30,744 INFO  [org.hibernate.search.Version] (http-/127.0.0.1:8080-8)
> HSEARCH000034: Hibernate Search 4.2.0.Final-redhat-4
> 12:41:31,228 INFO  [org.infinispan.jmx.CacheJmxRegistration]
> (http-/127.0.0.1:8080-8) ISPN000031: MBeans were successfully registered to
> the platform MBean server.
> 12:41:31,229 INFO  [org.jboss.as.clustering.infinispan]
> (http-/127.0.0.1:8080-8) JBAS010281: Started sramp/default cache from
> modeshape container
> 12:41:38,778 ERROR [stderr] (http-/127.0.0.1:8080-2)
> org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking
> endpoint
> 12:41:38,779 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.io.AbstractRPCMethodCallback.
> invokeMethodFromMessage(AbstractRPCMethodCallback.java:52)
> 12:41:38,779 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.io.ValueReplyRPCEndpointCallback.
> callback(ValueReplyRPCEndpointCallback.java:22)
> 12:41:38,780 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.io.RemoteServiceCallback.
> callback(RemoteServiceCallback.java:54)
> 12:41:38,780 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.cdi.server.CDIExtensionPoints$3.callback(CDIExtensionPoints.
> java:516)
> 12:41:38,780 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.DeliveryPlan.deliver(DeliveryPlan.java:51)
> 12:41:38,781 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.ServerMessageBusImpl.
> sendGlobal(ServerMessageBusImpl.java:294)
> 12:41:38,781 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.SimpleDispatcher.dispatchGlobal(SimpleDispatcher.
> java:46)
> 12:41:38,782 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.
> java:92)
> 12:41:38,782 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.service.ErraiServiceImpl.store(ErraiServiceImpl.
> java:109)
> 12:41:38,782 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.servlet.DefaultBlockingServlet.
> doPost(DefaultBlockingServlet.java:139)
> 12:41:38,783 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> javax.servlet.http.HttpServlet.service(HttpServlet.java:754)
> 12:41:38,783 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
> 12:41:38,784 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> internalDoFilter(ApplicationFilterChain.java:295)
> 12:41:38,784 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> doFilter(ApplicationFilterChain.java:214)
> 12:41:38,784 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.dtgov.ui.server.filters.LocaleFilter.doFilter(LocaleFilter.java:
> 63)
> 12:41:38,785 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> internalDoFilter(ApplicationFilterChain.java:246)
> 12:41:38,785 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> doFilter(ApplicationFilterChain.java:214)
> 12:41:38,785 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.
> java:230)
> 12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.
> java:149)
> 12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.
> java:481)
> 12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.as.web.security.SecurityContextAssociationValve.
> invoke(SecurityContextAssociationValve.java:169)
> 12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
> 12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
> 12:41:38,786 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:
> 102)
> 12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
> 12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
> 12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.
> process(Http11Protocol.java:653)
> 12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
> 12:41:38,787 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> java.lang.Thread.run(Thread.java:724)
> 12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) Caused by:
> org.overlord.dtgov.ui.client.shared.exceptions.DtgovUiException:
> org.overlord.sramp.atom.err.SrampAtomException: Invalid classified-by (it is
> either an invalid URI or it is not defined by an S-RAMP ontology):
> http://www.jboss.org/overlord/deployment-status.owl#Lifecycle
> 12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.dtgov.ui.server.services.DeploymentsService.
> search(DeploymentsService.java:119)
> 12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> 12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.
> java:43)
> 12:41:38,788 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> java.lang.reflect.Method.invoke(Method.java:606)
> 12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.errai.bus.server.io.AbstractRPCMethodCallback.
> invokeMethodFromMessage(AbstractRPCMethodCallback.java:43)
> 12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	... 28 more
> 12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) Caused by:
> org.overlord.sramp.atom.err.SrampAtomException: Invalid classified-by (it is
> either an invalid URI or it is not defined by an S-RAMP ontology):
> http://www.jboss.org/overlord/deployment-status.owl#Lifecycle
> 12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.JCRPersistence.resolve(JCRPersistence.java:
> 621)
> 12:41:38,789 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.JCRPersistence.resolveAll(JCRPersistence.
> java:646)
> 12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> resolveArgumentsToClassifications(SrampToJcrSql2QueryVisitor.java:409)
> 12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:322)
> 12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.FunctionCall.accept(FunctionCall.
> java:77)
> 12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:490)
> 12:41:38,790 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.SubartifactSet.
> accept(SubartifactSet.java:106)
> 12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:262)
> 12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.EqualityExpr.accept(EqualityExpr.
> java:82)
> 12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:422)
> 12:41:38,791 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.OrExpr.accept(OrExpr.java:43)
> 12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:229)
> 12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.AndExpr.accept(AndExpr.java:43)
> 12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:284)
> 12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.Expr.accept(Expr.java:58)
> 12:41:38,792 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:435)
> 12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.Predicate.accept(Predicate.java:57)
> 12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.SrampToJcrSql2QueryVisitor.
> visit(SrampToJcrSql2QueryVisitor.java:152)
> 12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.common.query.xpath.ast.Query.accept(Query.java:86)
> 12:41:38,793 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.JCRSrampQuery.
> createSql2Query(JCRSrampQuery.java:135)
> 12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.jcr.query.JCRSrampQuery.
> executeQuery(JCRSrampQuery.java:89)
> 12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.repository.query.AbstractSrampQueryImpl.
> executeQuery(AbstractSrampQueryImpl.java:176)
> 12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.server.atom.services.AbstractFeedResource.
> createArtifactFeed(AbstractFeedResource.java:84)
> 12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.server.atom.services.QueryResource.query(QueryResource.
> java:158)
> 12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.server.atom.services.QueryResource.
> queryFromPost(QueryResource.java:124)
> 12:41:38,794 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
> 12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.
> java:43)
> 12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> java.lang.reflect.Method.invoke(Method.java:606)
> 12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:
> 167)
> 12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:
> 269)
> 12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:227)
> 12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:216)
> 12:41:38,795 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.core.SynchronousDispatcher.
> getResponse(SynchronousDispatcher.java:542)
> 12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.
> java:524)
> 12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.
> java:126)
> 12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.
> service(ServletContainerDispatcher.java:208)
> 12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.
> service(HttpServletDispatcher.java:55)
> 12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.
> service(HttpServletDispatcher.java:50)
> 12:41:38,796 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
> 12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> internalDoFilter(ApplicationFilterChain.java:295)
> 12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> doFilter(ApplicationFilterChain.java:214)
> 12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.overlord.sramp.server.filters.LocaleFilter.doFilter(LocaleFilter.java:59)
> 12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> internalDoFilter(ApplicationFilterChain.java:246)
> 12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.ApplicationFilterChain.
> doFilter(ApplicationFilterChain.java:214)
> 12:41:38,797 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.
> java:230)
> 12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.
> java:149)
> 12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.
> java:481)
> 12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.jboss.as.web.security.SecurityContextAssociationValve.
> invoke(SecurityContextAssociationValve.java:169)
> 12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
> 12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
> 12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:
> 102)
> 12:41:38,798 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
> 12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:856)
> 12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> Http11ConnectionHandler.process(Http11Protocol.java:653)
> 12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	at
> Worker.run(JIoEndpoint.java:920)
> 12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) 	... 1 more
> 12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) *** Message delivery
> failure ***
> 12:41:38,799 ERROR [stderr] (http-/127.0.0.1:8080-2) Bus:
> org.jboss.errai.bus.server.ServerMessageBusImpl@43b40ca0
> 12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) Message:
> CommandType=search:org.overlord.dtgov.ui.client.shared.beans.
> DeploymentsFilterBean:java.lang.String:int:,
> ErrorTo=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC.
> search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.
> lang.String:int::1:Errors:RPC,
> ReplyTo=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC.
> search:org.overlord.dtgov.ui.client.shared.beans.DeploymentsFilterBean:java.
> lang.String:int::1:RespondTo:RPC,
> ToSubject=org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:
> RPC,
> MethodParms=[org.overlord.dtgov.ui.client.shared.beans.
> DeploymentsFilterBean@1b4d89f, , 1]
> 12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) errorMessage: Error
> calling remote service:
> org.overlord.dtgov.ui.client.shared.services.IDeploymentsService:RPC
> 12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) exception:
> org.jboss.errai.bus.client.api.base.MessageDeliveryFailure: error invoking
> endpoint
> 12:41:38,800 ERROR [stderr] (http-/127.0.0.1:8080-2) disconnect: false
Comment 10 Eric Wittmann 2013-09-09 08:11:33 EDT
Right!

Once the server is running, you can run the following command from the jboss-eap-6.1 directory:

./bin/s-ramp.sh -f dtgov-sramp-repo-seed-cli-commands.txt

Note: I had to chmod 755 the s-ramp.sh script to make it executable.
Comment 11 Stefan Bunciak 2013-09-10 03:31:12 EDT
(In reply to Eric Wittmann from comment #10)
> Right!
> 
> Once the server is running, you can run the following command from the
> jboss-eap-6.1 directory:
> 
> ./bin/s-ramp.sh -f dtgov-sramp-repo-seed-cli-commands.txt
> 
> Note: I had to chmod 755 the s-ramp.sh script to make it executable.

Is there a Jira/BZ issue for this? I'm also needed to chmod the s-ramp.sh after s-ramp installation. Shouldn't this be handled also by the FSW S-RAMP installer?

Note You need to log in before you can comment on or make changes to this bug.