Bug 997613 - no longer able to create snapshot smaller then 3 chunks
no longer able to create snapshot smaller then 3 chunks
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.0
x86_64 Linux
unspecified Severity low
: rc
: ---
Assigned To: LVM and device-mapper development team
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-15 15:17 EDT by Corey Marthaler
Modified: 2013-08-19 03:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 03:17:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2013-08-15 15:17:30 EDT
Description of problem:
The following test case no longer passes due to the new 3 chunk snapshot minimum. Is this expected going forward? Should all "small snap" test cases now be changed to be at least 3 chunks?

SCENARIO - [create_snap_on_1Kextent_vg]
Create a small snap on a VG with an extent size of only 1K
Recreating VG with smaller (1K) extent size
vgcreate -s 1K snapper /dev/vdg1
Creating small origin and snap
lvcreate -l 10 -n origin snapper
qalvm-01: lvcreate -l 10 -n small_snap1 -s /dev/snapper/origin
  Unable to create a snapshot smaller than 3 chunks (12 extents, 12.00 KiB).

[root@qalvm-01 ~]# lvcreate -l 10 -n small_snap1 -s /dev/snapper/origin
  Unable to create a snapshot smaller than 3 chunks (12 extents, 12.00 KiB).
[root@qalvm-01 ~]# lvcreate -l 11 -n small_snap1 -s /dev/snapper/origin
  Unable to create a snapshot smaller than 3 chunks (12 extents, 12.00 KiB).
[root@qalvm-01 ~]# lvcreate -l 12 -n small_snap1 -s /dev/snapper/origin
  Logical volume "small_snap1" created


Version-Release number of selected component (if applicable):
3.10.0-0.rc5.61.el7.x86_64
lvm2-2.02.101-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
lvm2-libs-2.02.101-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
lvm2-cluster-2.02.101-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
device-mapper-1.02.80-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
device-mapper-libs-1.02.80-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
device-mapper-event-1.02.80-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
device-mapper-event-libs-1.02.80-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
cmirror-2.02.101-0.122.el7    BUILT: Wed Aug 14 08:27:33 CDT 2013
Comment 1 Marian Csontos 2013-08-19 03:17:02 EDT
Added by Upstream commit 59962d8d3e1c402da02f7bf1b09978f570fd09d5:

    snapshot: require 3 chunks for creation
    
    There is no point in creation of 2chunks snapshot,
    since the snapshot is invalidated immeditelly with the first write
    as there is no free chunk for COW blocks
    (2 chunks are used by the snap header and the 1st. metadata chunk).
    
    Enhance error message about the lowest usable size.

Update STS please.
Comment 2 Marian Csontos 2013-08-19 03:36:11 EDT
Added by Upstream commit 59962d8d3e1c402da02f7bf1b09978f570fd09d5:

    snapshot: require 3 chunks for creation
    
    There is no point in creation of 2chunks snapshot,
    since the snapshot is invalidated immeditelly with the first write
    as there is no free chunk for COW blocks
    (2 chunks are used by the snap header and the 1st. metadata chunk).
    
    Enhance error message about the lowest usable size.

Update STS please.
Comment 3 Marian Csontos 2013-08-19 03:38:46 EDT
Ignore duplicate comment #2. Seems like the change collided with itself...

Note You need to log in before you can comment on or make changes to this bug.