Bug 997720 - Balloon a Win7-64 guest very slowly
Balloon a Win7-64 guest very slowly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: 7.0
Assigned To: Gal Hammer
Virtualization Bugs
:
: 921891 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 00:57 EDT by CongLi
Modified: 2014-06-18 04:57 EDT (History)
15 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-75
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:23:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description CongLi 2013-08-16 00:57:57 EDT
Description of problem:
Balloon a Win7-64 guest very slowly.

Version-Release number of selected component (if applicable):
kernel-2.6.32-411.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.389.el6.x86_64
virtio-win-prewhql-0.1-67.iso

How reproducible:
100%

Steps to Reproduce:
1. Boot a Win7-64 guest with mem=8192 :
/usr/libexec/qemu-kvm \
    -S \
    -name 'virt-tests-vm1' \
    -nodefaults \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20130809-150153-w7QnGFsU,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control \
    -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130809-150153-w7QnGFsU,server,nowait \
    -device isa-serial,chardev=serial_id_serial1 \
    -chardev socket,id=seabioslog_id_20130809-150153-w7QnGFsU,path=/tmp/seabios-20130809-150153-w7QnGFsU,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20130809-150153-w7QnGFsU,iobase=0x402 \
    -device ich9-usb-uhci1,id=usb1,bus=pci.0,addr=0x4 \
    -drive file='/home/win7-64-virtio.qcow2',index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=off,format=qcow2,aio=native \
    -device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,bootindex=0 \
    -device virtio-net-pci,netdev=idN4f4DY,mac='9a:eb:ec:ed:ee:ef',bus=pci.0,addr=0x3,id='idYpIz37' \
    -netdev tap,id=idN4f4DY,vhost=on \
    -m 8192 \
    -smp 16,maxcpus=16,cores=4,threads=2,sockets=2 \
    -cpu 'Opteron_G4',,hv_relaxed \
    -M pc \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 \
    -vnc :0 \
    -vga std \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off   \
    -balloon virtio \
    -enable-kvm \
    -monitor stdio \
    -drive file='/home/virtio-win-prewhql-0.1-67.iso',index=1,if=none,id=drive-ide0-0-0,media=cdrom,format=raw \
    -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0 \

2. (qemu) info balloon
   balloon: actual=8192

3. (qemu) balloon 4096

Actual results:
Balloon from 8192MB to 4096MB, needs about 11mins, about 6.2MB/s.

Expected results:
Balloon should be faster.
Tested with Linux.6.4-64 guest, balloon evict just needs few seconds.

Additional info:
1. There is no load on guest & host.

guest:
Before balloon:
cpu: 0%
mem: 690MB

Balloon ing:
cpu: 6%
mem: 690MB -> 4.74GB

After balloon:
cpu: 0%
mem: 4.74GB

When balloon, cpu & mem increase smoothly.

2. Tested with Linux.6.4-64 guest, balloon evict just needs few seconds.

3. Tested with virtio-win-1.6.5-6.el6_4, also slowly.

4. cpuinfo:
processor	: 31
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 1
model name	: AMD Opteron(TM) Processor 6272                 
stepping	: 2
cpu MHz		: 2099.977
cache size	: 2048 KB
physical id	: 1
siblings	: 16
core id		: 7
cpu cores	: 8
apicid		: 79
initial apicid	: 47
fpu		: yes
f2.6.32-411.el6.x86_64pu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm constant_tsc rep_good nonstop_tsc extd_apicid amd_dcm aperfmperf pni pclmulqdq monitor ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs xop skinit wdt lwp fma4 nodeid_msr topoext perfctr_core cpb npt lbrv svm_lock nrip_save tsc_scale vmcb_clean flushbyasid decodeassists pausefilter pfthreshold
bogomips	: 4199.76
TLB size	: 1536 4K pages
clflush size	: 64
cache_alignment	: 64
address sizes	: 48 bits physical, 48 bits virtual
power management: ts ttp tm 100mhzsteps hwpstate cpb

5. mem:
# free -m
             total       used       free     shared    buffers     cached
Mem:         64374      24727      39647          0         45      23742
-/+ buffers/cache:        939      63435
Swap:        57343          0      57343
Comment 1 Mike Cao 2014-01-05 21:38:33 EST
*** Bug 921891 has been marked as a duplicate of this bug. ***
Comment 3 CongLi 2014-03-19 02:59:05 EDT
To a win7.x86_64 guest, balloon from 8192 to 4096:

1. Reproduce this bug on virtio-win-prewhql-0.1-67, balloon needs about few mins.

2. Verify it on virtio-win-prewhql-0.1-75, balloon just needs few seconds.

As the above info, I think this bug has been fixed.

Thanks,
Cong
Comment 4 Mike Cao 2014-03-19 03:00:26 EDT
Move status to VERIFID according comment #3
Comment 5 Ludek Smid 2014-06-13 06:23:07 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.