Bug 997893 - remote-viewer does not exit gracefully after File transfer
remote-viewer does not exit gracefully after File transfer
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 08:07 EDT by Marian Krcmarik
Modified: 2013-11-21 03:27 EST (History)
5 users (show)

See Also:
Fixed In Version: spice-gtk-0.20-6.el6
Doc Type: Bug Fix
Doc Text:
No doc needed, this bug was introduced as part of the rebase to 0.20 for 6.5
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 03:27:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
r-v debug log (53.97 KB, text/plain)
2013-08-16 08:09 EDT, Marian Krcmarik
no flags Details

  None (edit)
Description Marian Krcmarik 2013-08-16 08:07:54 EDT
Description of problem:
remote-viewer is not closed gracefully after file transfer from client to guest was performed, remote-viewer process hangs on received SIGINT until It's kill by SIGKILL.

Version-Release number of selected component (if applicable):
All component RHEL6.5 candidate
spice-gtk-python-0.20-5.el6.x86_64
spice-gtk-tools-0.20-5.el6.x86_64
spice-gtk-0.20-5.el6.x86_64
virt-viewer-0.5.6-6.el6.x86_64
spice-server-0.12.4-2.el6.x86_64
spice-vdagent-0.14.0-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Establish spice session to a RHEL guest.
2. Perform File transfer from client to guest.
3. Close remote-viewer with X button.

Actual results:
remote-viewer process receives SIGINT and hangs

Expected results:
graceful termination

Additional info:
I am not sure about right component but If spice-vdagentd is stopped after step 2. from "Steps to reproduce" remote-viewer is terminated nicely.
Comment 1 Marian Krcmarik 2013-08-16 08:09:08 EDT
Created attachment 787228 [details]
r-v debug log
Comment 2 Hans de Goede 2013-08-19 11:05:36 EDT
Hi Marian,

Thanks for the bug report. This is an interesting bug, I did not expect any bugs in the file xfer stuff since I've done some serious stress testing with it. But it turns out this is a RHEL-6 only bug, RHEL-6's glib does not have g_slist_free_full, and our own version of it (only used with older glib's) is broken. Which is why my testing (done under Fedora) did not hit this.

Anyways it is fixed now, the fix is here:
http://lists.freedesktop.org/archives/spice-devel/2013-August/014190.html

Changing component to spice-gtk.

Regards,

Hans
Comment 6 errata-xmlrpc 2013-11-21 03:27:51 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1577.html

Note You need to log in before you can comment on or make changes to this bug.