This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 997902 - GlusterFS mount of x86_64 served volume from i386 breaks
GlusterFS mount of x86_64 served volume from i386 breaks
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: io-cache (Show other bugs)
3.4.0
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra G
:
: 999356 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 09:05 EDT by Morten Johansen
Modified: 2014-04-17 07:45 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:45:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from client. Log spans mount, access (mount breaks) and unmount (15.75 KB, text/plain)
2013-08-16 09:07 EDT, Morten Johansen
no flags Details

  None (edit)
Description Morten Johansen 2013-08-16 09:05:43 EDT
Description of problem:
After mounting a glusterfs volume on RHEL/CentOS 5 i386, trying to access data breaks the mount with "Transport endpoint not connected" error.
"ls" command will give you some files at first. After error message has occured, all access i denied with the same error message. Unmount works fine, and after mount again the same problem is consistently reproduced.

Version-Release number of selected component (if applicable):
All bits running GlusterFS 3.4.0-8 RPM packages

How reproducible: Always. Tested with clean installed CentOS 5. Cannot reproduce on x86_64 client, only i386.

Steps to Reproduce:
1. Run GlusterFS 3.4.0-8 (presumably on x86_64 servers, that is our test environment)
2. Install glusterfs-fuse on i386 client, modprobe fuse and mount volume.
3. Access data until error occurs. simple "ls" in directories will produce the error.



Additional info:

Example log from client: https://dl.dropboxusercontent.com/u/683331/test.log.txt
(Also attached)
Comment 1 Morten Johansen 2013-08-16 09:07:04 EDT
Created attachment 787238 [details]
Log from client. Log spans mount, access (mount breaks) and unmount
Comment 2 Anand Avati 2013-08-21 20:56:42 EDT
*** Bug 999356 has been marked as a duplicate of this bug. ***
Comment 3 Anand Avati 2013-08-21 20:56:43 EDT
REVIEW: http://review.gluster.org/5682 (io-cache: fix unsafe typcasting of pointer to uint64) posted (#1) for review on master by Anand Avati (avati@redhat.com)
Comment 4 Anand Avati 2013-08-22 14:43:57 EDT
COMMIT: http://review.gluster.org/5682 committed in master by Anand Avati (avati@redhat.com) 
------
commit 498a26b0307f2050e245c8d9330ba447c792d55d
Author: Anand Avati <avati@redhat.com>
Date:   Wed Aug 21 17:34:02 2013 -0700

    io-cache: fix unsafe typcasting of pointer to uint64
    
    The typecast of pointer to uint64_t *, followed by setting of
    64bit in inode_ctx_get() results in memory corruption on 32bit
    system.
    
    Change-Id: I32fa3bf3b853ed2690a9b9a471099a59b9d7186a
    BUG: 997902
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5682
    Tested-by: Morten Johansen <morten@bzzt.no>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Santosh Pradhan <spradhan@redhat.com>
    Reviewed-by: Brian Foster <bfoster@redhat.com>
Comment 5 Anand Avati 2013-09-09 20:54:10 EDT
REVIEW: http://review.gluster.org/5879 (io-cache: fix unsafe typcasting of pointer to uint64) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 6 Anand Avati 2013-09-09 21:06:36 EDT
REVIEW: http://review.gluster.org/5879 (io-cache: fix unsafe typcasting of pointer to uint64) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 7 Anand Avati 2013-09-10 04:22:31 EDT
COMMIT: http://review.gluster.org/5879 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 6f3f1a529663a705a98142b91f6b3a6e4c8fe983
Author: Anand Avati <avati@redhat.com>
Date:   Wed Aug 21 17:34:02 2013 -0700

    io-cache: fix unsafe typcasting of pointer to uint64
    
    The typecast of pointer to uint64_t *, followed by setting of
    64bit in inode_ctx_get() results in memory corruption on 32bit
    system.
    
    Change-Id: I32fa3bf3b853ed2690a9b9a471099a59b9d7186a
    BUG: 997902
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5879
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 8 Niels de Vos 2014-04-17 07:45:58 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.