Bug 997908 - [abrt] libvirt-daemon-1.0.5.5-1.fc19: __alloc_dir: Process /usr/sbin/libvirtd was killed by signal 11 (SIGSEGV)
[abrt] libvirt-daemon-1.0.5.5-1.fc19: __alloc_dir: Process /usr/sbin/libvirtd...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
abrt_hash:55f1722b979ffc9683bf10733c2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 09:23 EDT by Christian Provido
Modified: 2013-08-30 18:49 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-30 18:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (97.53 KB, text/plain)
2013-08-16 09:23 EDT, Christian Provido
no flags Details
File: cgroup (162 bytes, text/plain)
2013-08-16 09:23 EDT, Christian Provido
no flags Details
File: core_backtrace (23.77 KB, text/plain)
2013-08-16 09:23 EDT, Christian Provido
no flags Details
File: dso_list (9.49 KB, text/plain)
2013-08-16 09:23 EDT, Christian Provido
no flags Details
File: environ (114 bytes, text/plain)
2013-08-16 09:23 EDT, Christian Provido
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-16 09:24 EDT, Christian Provido
no flags Details
File: maps (45.71 KB, text/plain)
2013-08-16 09:24 EDT, Christian Provido
no flags Details
File: open_fds (706 bytes, text/plain)
2013-08-16 09:24 EDT, Christian Provido
no flags Details
File: proc_pid_status (899 bytes, text/plain)
2013-08-16 09:24 EDT, Christian Provido
no flags Details
File: var_log_messages (13.61 KB, text/plain)
2013-08-16 09:24 EDT, Christian Provido
no flags Details

  None (edit)
Description Christian Provido 2013-08-16 09:23:12 EDT
Version-Release number of selected component:
libvirt-daemon-1.0.5.5-1.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/sbin/libvirtd
crash_function: __alloc_dir
executable:     /usr/sbin/libvirtd
kernel:         3.9.5-301.fc19.x86_64
runlevel:       unknown
uid:            0

Truncated backtrace:
Thread no. 1 (7 frames)
 #2 __alloc_dir at ../sysdeps/posix/opendir.c:206
 #3 virNWFilterLoadAllConfigs at conf/nwfilter_conf.c:3116
 #4 nwfilterStateInitialize at nwfilter/nwfilter_driver.c:232
 #5 virStateInitialize at libvirt.c:833
 #6 daemonRunStateInit at libvirtd.c:876
 #7 virThreadHelper at util/virthreadpthread.c:161
 #9 clone at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113
Comment 1 Christian Provido 2013-08-16 09:23:27 EDT
Created attachment 787248 [details]
File: backtrace
Comment 2 Christian Provido 2013-08-16 09:23:35 EDT
Created attachment 787249 [details]
File: cgroup
Comment 3 Christian Provido 2013-08-16 09:23:43 EDT
Created attachment 787250 [details]
File: core_backtrace
Comment 4 Christian Provido 2013-08-16 09:23:50 EDT
Created attachment 787251 [details]
File: dso_list
Comment 5 Christian Provido 2013-08-16 09:23:57 EDT
Created attachment 787252 [details]
File: environ
Comment 6 Christian Provido 2013-08-16 09:24:04 EDT
Created attachment 787254 [details]
File: limits
Comment 7 Christian Provido 2013-08-16 09:24:18 EDT
Created attachment 787255 [details]
File: maps
Comment 8 Christian Provido 2013-08-16 09:24:26 EDT
Created attachment 787256 [details]
File: open_fds
Comment 9 Christian Provido 2013-08-16 09:24:33 EDT
Created attachment 787257 [details]
File: proc_pid_status
Comment 10 Christian Provido 2013-08-16 09:24:42 EDT
Created attachment 787259 [details]
File: var_log_messages
Comment 11 Cole Robinson 2013-08-30 18:49:30 EDT
From the full backtrace, it just looks like opendir("/etc/libvirt/nwfilter") is segfaulting. Maybe your machine was OOM or you have memory issues, but it doesn't look like libvirt is doing anything wrong here, and there's not much we can do if a legitimate glibc call segfaults. Closing as NOTABUG

Note You need to log in before you can comment on or make changes to this bug.