Bug 997936 - [abrt] youtube-dl-2013.08.02-1.fc19: YoutubeDL.py:145:to_stderr:IOError: [Errno 5] Input/output error
[abrt] youtube-dl-2013.08.02-1.fc19: YoutubeDL.py:145:to_stderr:IOError: [Err...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: youtube-dl (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
abrt_hash:329e554b5ad832611cbcb3b77a3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 11:03 EDT by Joshua Allen Holm
Modified: 2013-09-11 10:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 10:17:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.24 KB, text/plain)
2013-08-16 11:03 EDT, Joshua Allen Holm
no flags Details
File: environ (3.73 KB, text/plain)
2013-08-16 11:03 EDT, Joshua Allen Holm
no flags Details

  None (edit)
Description Joshua Allen Holm 2013-08-16 11:03:36 EDT
Version-Release number of selected component:
youtube-dl-2013.08.02-1.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        python /usr/bin/youtube-dl https://www.youtube.com/watch?v=1mxPFHBCfuU
dso_list:       python-libs-2.7.5-3.fc19.x86_64
executable:     /usr/bin/youtube-dl
kernel:         3.10.4-300.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
YoutubeDL.py:145:to_stderr:IOError: [Errno 5] Input/output error

Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/bin/youtube-dl/__main__.py", line 18, in <module>
    youtube_dl.main()
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 639, in main
    _real_main(argv)
  File "/usr/bin/youtube-dl/youtube_dl/__init__.py", line 623, in _real_main
    retcode = ydl.download(all_urls)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 575, in download
    self.report_error(u'unable to download video')
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 203, in report_error
    self.trouble(error_message, tb)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 161, in trouble
    self.to_stderr(message)
  File "/usr/bin/youtube-dl/youtube_dl/YoutubeDL.py", line 145, in to_stderr
    sys.stderr.write(output)
IOError: [Errno 5] Input/output error

Local variables in innermost frame:
output: 'ERROR: unable to download video\n'
message: u'ERROR: unable to download video'
self: <youtube_dl.YoutubeDL.YoutubeDL object at 0x1168a50>
Comment 1 Joshua Allen Holm 2013-08-16 11:03:42 EDT
Created attachment 787299 [details]
File: backtrace
Comment 2 Joshua Allen Holm 2013-08-16 11:03:45 EDT
Created attachment 787300 [details]
File: environ
Comment 3 Christopher Meng 2013-09-10 21:21:23 EDT
Have you tried again with the same URL?
Comment 4 Joshua Allen Holm 2013-09-11 09:56:50 EDT
Yes. Immediately after youtube-dl crashes I can start it up again with the same url and it works fine. According to ABRT, youtube-dl has crashed in the same way 5 times on my computer and, to the best of my recollection, all five times involved a different url.
Comment 5 Christopher Meng 2013-09-11 10:17:52 EDT
Yes, sometimes ABRT is caring too much about software segfaults. I will close it as NOTABUG as this might caused by unstable network or ABRT.

If you can't download tubes, please report a new bug.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.