Bug 997952 - dhcp used even if yes answered to switch to manual after setting IP in nmcli
dhcp used even if yes answered to switch to manual after setting IP in nmcli
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: NetworkManager (Show other bugs)
7.0
All Linux
low Severity low
: beta
: 7.0
Assigned To: Jirka Klimes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 11:34 EDT by Vladimir Benes
Modified: 2013-09-02 11:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 11:26:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Benes 2013-08-16 11:34:22 EDT
Description of problem:
I've just added ip to new ethernet connection, and was asked if I want to switch to manual, I answered yes, saved, quitted. When connection started, it was dhcp again. When I add static/manual manually everything works correctly.

Version-Release number of selected component (if applicable):
NetworkManager-0.9.9.0-9.git20130807.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.add ethernet connection via nmcli connection add type ethernet...
2.edit that connection via nmcli connection edit id ..
3.submit set ipv4.address 192.168.122.253 for example
4.when asked if you want to switch to manual answer yes
5.start connection by nmcli connection up id..

Actual results:
dhcp used

Expected results:
ip set correctly

Additional info:
if I set yes or no it behaves the same
Comment 2 Jirka Klimes 2013-09-02 08:22:57 EDT
I can't reproduce this bug. When I set ipv4.address, I am asked "Do you also want to set 'ipv4.method' to 'manual'? [yes]:". When I answer "yes", the method is properly set to manual. And no DHCP is used while activating the connection.
Maybe, you answered "no" and method was left 'auto'.
Comment 3 Vladimir Benes 2013-09-02 08:33:42 EDT
(In reply to Jirka Klimes from comment #2)
> I can't reproduce this bug. When I set ipv4.address, I am asked "Do you also
> want to set 'ipv4.method' to 'manual'? [yes]:". When I answer "yes", the
> method is properly set to manual. And no DHCP is used while activating the
> connection.
> Maybe, you answered "no" and method was left 'auto'.

try IP w/o prefix.. and as description says: "Missing prefix is regarded as prefix of 32." it should work

Note You need to log in before you can comment on or make changes to this bug.