Bug 997986 - [abrt] sphinxtrain-1.0.8-5.fc19: sphinxtrain:34:setup:IOError: [Errno 2] No such file or directory: '/usr/lib/sphinxtrain/etc/sphinx_train.cfg'
[abrt] sphinxtrain-1.0.8-5.fc19: sphinxtrain:34:setup:IOError: [Errno 2] No s...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sphinxtrain (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jerry James
Fedora Extras Quality Assurance
abrt_hash:2690091b1ef7baa3bac20a67094...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 13:18 EDT by reiayanami01
Modified: 2013-08-28 17:31 EDT (History)
1 user (show)

See Also:
Fixed In Version: sphinxtrain-1.0.8-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 17:29:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (643 bytes, text/plain)
2013-08-16 13:18 EDT, reiayanami01
no flags Details
File: environ (3.62 KB, text/plain)
2013-08-16 13:18 EDT, reiayanami01
no flags Details

  None (edit)
Description reiayanami01 2013-08-16 13:18:44 EDT
Description of problem:
The bug appeared during a change in the configuration of Simon (speech recognition soft.);
Instead of using Voxforge vox model, I choose to use the Sphinx base model, then the bug appeared.

Version-Release number of selected component:
sphinxtrain-1.0.8-5.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/sphinxtrain -t default{36a4a9a3-163e-4559-8bac-0d646246698c} setup
executable:     /usr/bin/sphinxtrain
kernel:         3.10.6-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
sphinxtrain:34:setup:IOError: [Errno 2] No such file or directory: '/usr/lib/sphinxtrain/etc/sphinx_train.cfg'

Traceback (most recent call last):
  File "/usr/bin/sphinxtrain", line 135, in <module>
    main()
  File "/usr/bin/sphinxtrain", line 125, in main
    setup(task)
  File "/usr/bin/sphinxtrain", line 34, in setup
    for line in open(sphinxpath + "/etc/sphinx_train.cfg", "r"):
IOError: [Errno 2] No such file or directory: '/usr/lib/sphinxtrain/etc/sphinx_train.cfg'

Local variables in innermost frame:
out_cfg: <open file 'etc/sphinx_train.cfg', mode 'w' at 0x7f19cc253780>
task: 'default{36a4a9a3-163e-4559-8bac-0d646246698c}'
Comment 1 reiayanami01 2013-08-16 13:18:47 EDT
Created attachment 787364 [details]
File: backtrace
Comment 2 reiayanami01 2013-08-16 13:18:50 EDT
Created attachment 787365 [details]
File: environ
Comment 3 Jerry James 2013-08-20 00:32:16 EDT
This is due to some parts of the code assuming that everything will be installed into /usr/lib.  I have a patch for the problem, and will do new builds tonight.
Comment 4 Fedora Update System 2013-08-20 00:49:49 EDT
sphinxtrain-1.0.8-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sphinxtrain-1.0.8-8.fc19
Comment 5 Fedora Update System 2013-08-20 00:49:58 EDT
sphinxtrain-1.0.8-8.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sphinxtrain-1.0.8-8.fc18
Comment 6 Fedora Update System 2013-08-20 20:02:52 EDT
Package sphinxtrain-1.0.8-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sphinxtrain-1.0.8-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15043/sphinxtrain-1.0.8-8.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-08-28 17:29:14 EDT
sphinxtrain-1.0.8-8.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2013-08-28 17:31:52 EDT
sphinxtrain-1.0.8-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.