Bug 998017 - [abrt] libvirt-daemon-1.0.5.5-1.fc19: virClassIsDerivedFrom: Process /usr/sbin/libvirtd was killed by signal 11 (SIGSEGV)
[abrt] libvirt-daemon-1.0.5.5-1.fc19: virClassIsDerivedFrom: Process /usr/sbi...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
abrt_hash:b4648b6e3fe309672f8078767f9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 14:29 EDT by Don Geronimo
Modified: 2015-09-03 14:47 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 09:21:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (28.38 KB, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: core_backtrace (20.62 KB, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: dso_list (9.64 KB, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: environ (221 bytes, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: maps (26.61 KB, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: open_fds (618 bytes, text/plain)
2013-08-16 14:29 EDT, Don Geronimo
no flags Details
File: proc_pid_status (790 bytes, text/plain)
2013-08-16 14:30 EDT, Don Geronimo
no flags Details
File: var_log_messages (4.87 KB, text/plain)
2013-08-16 14:30 EDT, Don Geronimo
no flags Details

  None (edit)
Description Don Geronimo 2013-08-16 14:29:07 EDT
Description of problem:
1. Start Gnome Boxes.
2. Press "New" to create a new virtual machine.
3. Press "Continue," then select "ReactOS-BootCD.iso."
4. Press "Create."
5. After trying to go through the installation process, the virtual machine will hang with no CPU,  I/O, or Net activity.
6. Press "Force Shutdown," and press "OK"

I've only encountered a hang through the installation process when trying to install ReactOS or Windows XP ISOs or CDs through Gnome Boxes. Libvirt crashes on occasion when forcing the machine to shut down.

Version-Release number of selected component:
libvirt-daemon-1.0.5.5-1.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/sbin/libvirtd --timeout=30
crash_function: virClassIsDerivedFrom
executable:     /usr/sbin/libvirtd
kernel:         3.10.4-300.fc19.i686.PAE
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 virClassIsDerivedFrom at util/virobject.c:166
 #1 virObjectIsClass at util/virobject.c:364
 #2 virObjectLock at util/virobject.c:316
 #3 virDomainObjListFindByUUID at conf/domain_conf.c:982
 #4 qemuDomObjFromDomain at qemu/qemu_driver.c:197
 #5 qemuDomainIsPersistent at qemu/qemu_driver.c:1366
 #6 virDomainIsPersistent at libvirt.c:16572
 #7 remoteDispatchDomainIsPersistent at remote_dispatch.h:4760
 #8 remoteDispatchDomainIsPersistentHelper at remote_dispatch.h:4736
 #9 virNetServerProgramDispatchCall at rpc/virnetserverprogram.c:439
Comment 1 Don Geronimo 2013-08-16 14:29:15 EDT
Created attachment 787412 [details]
File: backtrace
Comment 2 Don Geronimo 2013-08-16 14:29:22 EDT
Created attachment 787413 [details]
File: cgroup
Comment 3 Don Geronimo 2013-08-16 14:29:28 EDT
Created attachment 787414 [details]
File: core_backtrace
Comment 4 Don Geronimo 2013-08-16 14:29:34 EDT
Created attachment 787415 [details]
File: dso_list
Comment 5 Don Geronimo 2013-08-16 14:29:40 EDT
Created attachment 787416 [details]
File: environ
Comment 6 Don Geronimo 2013-08-16 14:29:45 EDT
Created attachment 787417 [details]
File: limits
Comment 7 Don Geronimo 2013-08-16 14:29:51 EDT
Created attachment 787418 [details]
File: maps
Comment 8 Don Geronimo 2013-08-16 14:29:57 EDT
Created attachment 787419 [details]
File: open_fds
Comment 9 Don Geronimo 2013-08-16 14:30:02 EDT
Created attachment 787420 [details]
File: proc_pid_status
Comment 10 Don Geronimo 2013-08-16 14:30:08 EDT
Created attachment 787421 [details]
File: var_log_messages
Comment 11 Cole Robinson 2013-11-06 09:21:23 EST
Strange, there haven't been any other dupes, maybe this was fixed. Don, please make sure libvird is updated to latest F19 bits, and if you can still reproduce, please reopen.
Comment 12 Bastián Díaz 2015-09-03 14:47:57 EDT
Tested in:
Fedora 22 64bit (GNOME 3.16).

This bug is still valid for the case of using ReactOS 0.3.17 in gnome-boxes.
The system crashes and you need force shutdown of the virtual machine.

Note You need to log in before you can comment on or make changes to this bug.