Bug 998072 - Kernel panics at random with any 3.10.x kernel.
Kernel panics at random with any 3.10.x kernel.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-16 20:59 EDT by Michael
Modified: 2013-10-07 13:13 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 09:43:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Photo of a kernel panic (1.57 MB, image/jpeg)
2013-08-16 21:33 EDT, Michael
no flags Details
lspci (1.62 KB, text/plain)
2013-08-16 21:35 EDT, Michael
no flags Details
lspci (611.08 KB, image/png)
2013-08-24 17:12 EDT, aten
no flags Details
lspci (1.59 KB, text/plain)
2013-08-24 17:13 EDT, aten
no flags Details
modules (4.98 KB, text/plain)
2013-08-24 17:14 EDT, aten
no flags Details
kernel panic photo, left half (603.03 KB, image/jpeg)
2013-10-03 23:40 EDT, Peter H. Jones
no flags Details
kernel panic (right half) (558.88 KB, image/jpeg)
2013-10-03 23:56 EDT, Peter H. Jones
no flags Details
Patch to blacklist kernel update (417 bytes, text/plain)
2013-10-04 01:39 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Michael 2013-08-16 20:59:38 EDT
Description of problem: Kernel panics that occur a few times a day. Cannot reproduce and they seem to happen at random. So far today I have had 3 panics while running entirely different applications each time.

Version-Release number of selected component (if applicable): Linux Kernel version is 3.10.6-200.fc19.x86_64


How reproducible: Can't reproduce.


Steps to Reproduce:
1. /
2. /
3. /

Actual results: /


Expected results: /


Additional info: This happens on both Fedora 18 and Fedora 19. Using a 3.9 kernel works fine. My computer is a Lenovo ThinkPad T430 with Intel graphics.

Will attach a screenshot/photo soon.
Comment 1 Michael 2013-08-16 21:33:37 EDT
Created attachment 787493 [details]
Photo of a kernel panic

Sorry for the poor quality.
Comment 2 Michael 2013-08-16 21:35:47 EDT
Created attachment 787494 [details]
lspci
Comment 3 Josh Boyer 2013-08-19 11:37:42 EDT
You have an out-of-tree module loaded that isn't provided by Fedora.  Please test 3.10.7 without that module loaded and let us know if the issue still occurs.
Comment 4 Michael 2013-08-19 20:54:18 EDT
How would I check which module is causing the problem, and how would I disable it?
Comment 5 Josh Boyer 2013-08-20 08:41:20 EDT
cat /proc/modules and note which one contains the 'O' flag.  Then blacklist that one, or move it from /lib/modules/`uname -r`/ to some other location temporarily.
Comment 6 Michael 2013-08-20 12:55:52 EDT
Here's the output of cat /proc/modules. Still unsure what to look for, since I see lots of 0's which I doubt are out-of-tree modules: http://pastebin.com/hcR4dnEu

Sorry for the messing about; first time dealing with kernel problems.
Comment 7 Michael 2013-08-23 19:58:57 EDT
Hi. I've been using Linux 3.11-rc6 since last night and have not yet experienced any kernel panics. This issue is limited to just 3.10 it seems.
Comment 8 aten 2013-08-24 17:09:24 EDT
very similar issue in my case. Lenovo Thinkpad x230t. Up to several kernel panics per hour, started occurring about two weeks ago, roughly matching the update of the kernel to 3.10.* versions. I have created a thread here http://forums.fedoraforum.org/showthread.php?t=293478&page=2 and I'm attaching my system info and kernel panic snapshot.
Comment 9 aten 2013-08-24 17:12:35 EDT
Created attachment 789924 [details]
lspci

very similar issue in my case. Lenovo Thinkpad x230t. Up to several kernel panics per hour, started occurring about two weeks ago, roughly matching the update of the kernel to 3.10.* versions. I have created a thread here http://forums.fedoraforum.org/showthread.php?t=293478&page=2 and I'm attaching my system info and kernel panic snapshot.
Comment 10 aten 2013-08-24 17:13:52 EDT
Created attachment 789925 [details]
lspci
Comment 11 aten 2013-08-24 17:14:34 EDT
Created attachment 789926 [details]
modules
Comment 12 Josh Boyer 2013-09-18 16:43:17 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 13 Peter H. Jones 2013-10-03 23:40:19 EDT
Created attachment 807366 [details]
kernel panic photo, left half
Comment 14 Peter H. Jones 2013-10-03 23:56:24 EDT
Created attachment 807367 [details]
kernel panic (right half)

kernel-3.10.13-101.fc18.x86_64 seems to be the latest available. I don't see a kernel-3.11 in fc18, only in fc19.
Comment 15 Peter H. Jones 2013-10-04 00:23:13 EDT
This bug happens every time I boot in kernel-3.10.13-101.fc18.x86_64. The panic is easy to see if I remove rhgb and quiet from the kernel boot line. I am wondering if I should remove and yum blacklist that version, set the default grub2 entry to kernel-3.10.12, or install 3.11.1-200.fc19 ff. (This would result in a mixed-version system, of course.)
Comment 16 Peter H. Jones 2013-10-04 01:39:16 EDT
Created attachment 807403 [details]
Patch to blacklist kernel update

Patch to prevent updating to kernel-3.10.13-101.x86_64
Comment 17 Josh Boyer 2013-10-04 09:41:55 EDT
(In reply to Peter H. Jones from comment #15)
> This bug happens every time I boot in kernel-3.10.13-101.fc18.x86_64. The
> panic is easy to see if I remove rhgb and quiet from the kernel boot line. I
> am wondering if I should remove and yum blacklist that version, set the
> default grub2 entry to kernel-3.10.12, or install 3.11.1-200.fc19 ff. (This
> would result in a mixed-version system, of course.)

You have an entirely different problem than the original reporter of this bug.  Also, this is against F19, not F18.  You probably should have opened a new bug.

You likely either lack a corresponding initramfs file for 3.10.13-101.fc18.x86_64 in /boot, or your grub configuration file is lacking the initrd line for it.
Comment 18 Josh Boyer 2013-10-04 09:43:07 EDT
Given the original reporter said 3.11-rc6 was working, and F19 is now on 3.11.y stable kernels, I'm closing this bug.  If anyone else is seeing kernel panics, please open a new bug with the relevant details.
Comment 19 Peter H. Jones 2013-10-07 13:13:27 EDT
I concur with closing. I reinstalled kernel-3.10.13-101.fc18.x86_64, and it works fine. Perhaps when I was installing previously, I had shut down the system
not realizing the kernel install was incomplete. I suppose the problem could be avoided by updating the grub(2) entry as the last step in the installation process.

Note You need to log in before you can comment on or make changes to this bug.