Bug 998091 - yum update destroys all user modifications inside systemds httpd.service file.
yum update destroys all user modifications inside systemds httpd.service file.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 04:27 EDT by customercare
Modified: 2013-08-19 03:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 02:48:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description customercare 2013-08-17 04:27:57 EDT
Description of problem:

yum update destroys all user modifications inside systemds httpd.service file.

Version-Release number of selected component (if applicable):

2.4.6

How reproducible:

by the nature of this bug, it can usually only happen once a while ;)

Actual results:

service file gets overwritten.

Expected results:

a new service version must only be written with the .rpmnew extention, if the original service file has been altered.  


Additional info:

set the httpd.service and httpdclean.service files in the rpm spec to %config .

for more information why systemd files get altered by users , check this page:

http://marius.bloggt-in-braunschweig.de/2013/05/18/systemd-und-die-limits/
Comment 1 Jan Kaluža 2013-08-19 02:48:42 EDT
This is not a bug, check http://fedoraproject.org/wiki/Packaging:Systemd#.25files_section for more info:

> Systemd unit .service files must not be marked as %config files. If the user
> wants to reconfigure a .service file he should copy the .service file from
> /lib/systemd/system to /etc/systemd/system and edit it there. Unit files in
> /etc/systemd/system override those in /lib/systemd/system if they carry the
> same name.
Comment 2 customercare 2013-08-19 03:52:16 EDT
thx for supplying the hint, works like a charm now.

Note You need to log in before you can comment on or make changes to this bug.