Bug 998110 - thinkfan.conf should be installed to /etc/thinkfan.conf, not /etc/thinkfan/thinkfan.conf
thinkfan.conf should be installed to /etc/thinkfan.conf, not /etc/thinkfan/th...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: thinkfan (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matt Spaulding
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 05:45 EDT by Sandro Mani
Modified: 2013-08-18 06:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-17 23:38:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2013-08-17 05:45:32 EDT
Description of problem:
the thinkfan executable by default expects the config file to be under /etc/thinkfan.conf, unless one specifies the -c option when running thinkfan (in which case also the systemd unit needs to be modified accordingly).

Currently, as thinkfan is shipped, systemctl start thinkfan.service fails because it cannot find the config file.

Version-Release number of selected component (if applicable):
thinkfan-0.8.1-4.fc20.x86_64

How reproducible:
Always
Comment 1 Matt Spaulding 2013-08-17 23:38:48 EDT
New build thinkfan-0.8.1-5.fc20.x86_64 fixes this issue.
Comment 2 Sandro Mani 2013-08-18 06:15:36 EDT
Thanks. In case you might find it useful, I've locally updated the package to 0.9-beta2, the SRPM can be found here: http://smani.fedorapeople.org/thinkfan-0.9-0.1.beta2.fc20.src.rpm

Note You need to log in before you can comment on or make changes to this bug.