Bug 998145 - Polipo doesn't start as a service
Polipo doesn't start as a service
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: polipo (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 13:28 EDT by Martin Skjöldebrand
Modified: 2013-08-18 02:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 02:16:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Skjöldebrand 2013-08-17 13:28:13 EDT
Description of problem: The polipo service fails to start (by systemd).

9
Version-Release number of selected component (if applicable): 1.0.4.1-.fc19


How reproducible: 100% reproducible.


Steps to Reproduce:
1. Install the polipo package
2. Enable it with: "systemctl enable polipo.service"
3. Attempt to start it: "systemctl start polipo.service" (or reboot the system)


Actual results: The polipo service fails to start, from journalctl -xn;

-- Logs begin at Wed 2013-08-14 19:00:50 CEST, end at Sat 2013-08-17 19:25:41 CEST. --
Aug 17 19:23:52 dragon su[2398]: pam_succeed_if(su:auth): requirement "uid >= 1000" not met by user "root"
Aug 17 19:23:54 dragon su[2398]: FAILED SU (to mskjoldebrand) mskjoldebrand on none
Aug 17 19:24:00 dragon su[2405]: (to mskjoldebrand) mskjoldebrand on none
Aug 17 19:24:00 dragon su[2405]: pam_unix(su:session): session opened for user root by mskjoldebrand(uid=1000)
Aug 17 19:24:11 dragon systemd[1]: Starting A caching web proxy...
-- Subject: Unit polipo.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit polipo.service has begun starting up.
Aug 17 19:24:11 dragon polipo[2434]: Established listening socket on port 8118.
Aug 17 19:24:17 dragon fprintd[2399]: ** Message: No devices in use, exit
Aug 17 19:25:41 dragon systemd[1]: polipo.service operation timed out. Terminating.
Aug 17 19:25:41 dragon systemd[1]: Failed to start A caching web proxy.
-- Subject: Unit polipo.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit polipo.service has failed.
-- 
-- The result is failed.


Expected results: It should start.
Comment 1 Ed Greshko 2013-08-18 00:16:43 EDT
FYI, I cannot reproduce the problem....  System is newly upgraded F18->F19 regardless of what the hostname says.  :-)

Aug 18 12:13:06 f18x systemd[1]: Starting A caching web proxy...
-- Subject: Unit polipo.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit polipo.service has begun starting up.
Aug 18 12:13:07 f18x systemd[1]: Started A caching web proxy.
-- Subject: Unit polipo.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit polipo.service has finished starting up.
-- 
-- The start-up result is done.

[root@f18x ~]# ps -eaf | grep poli
polipo   19649     1  0 12:13 ?        00:00:00 /usr/bin/polipo -c /etc/polipo/config

[root@f18x ~]# netstat -nap | grep poli
tcp        0      0 127.0.0.1:8123          0.0.0.0:*               LISTEN      19649/polipo
Comment 2 Martin Skjöldebrand 2013-08-18 01:16:39 EDT
My computer is a newly installed with F19 KDE spinn HP 4530s laptop. I don't know if the hardware matters much or if the KDE spinn makes a difference. I'm not getting any more info than the "timeout" line.
Comment 3 Martin Skjöldebrand 2013-08-18 01:20:19 EDT
[root@dragon mskjoldebrand]# systemctl status polipo.service
polipo.service - A caching web proxy
   Loaded: loaded (/usr/lib/systemd/system/polipo.service; disabled)
   Active: failed (Result: timeout) since Sun 2013-08-18 07:13:10 CEST; 5min ago
     Docs: man:polipo(1)
           http://localhost:8123/
  Process: 8754 ExecStart=/usr/bin/polipo -c $CONFIG (code=exited, status=0/SUCCESS)

Aug 18 07:11:40 dragon polipo[8754]: Established listening socket on port 8118.
Aug 18 07:13:10 dragon systemd[1]: polipo.service operation timed out. Terminating.
Aug 18 07:13:10 dragon systemd[1]: Failed to start A caching web proxy.
Aug 18 07:13:10 dragon systemd[1]: Unit polipo.service entered failed state.
Comment 4 Martin Skjöldebrand 2013-08-18 02:15:51 EDT
It all was because a fubar'd config file. (Well, at least faulty). Feel free to close if I'm not allowed to.

Note You need to log in before you can comment on or make changes to this bug.