This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 998154 - Latest f18 update breaks ibus-anthy (Japanese input)
Latest f18 update breaks ibus-anthy (Japanese input)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-17 15:04 EDT by Richard W.M. Jones
Modified: 2013-09-23 22:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 22:57:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-08-17 15:04:15 EDT
Description of problem:

Updating to ibus 0:1.5.3-1.fc18 broken Japanese input completely.
Downgrading to:
  ibus.x86_64 0:1.4.99.20121109-8.fc18                                          
  ibus-anthy.x86_64 0:1.4.99.20121006-1.fc18                                    
  ibus-gtk2.x86_64 0:1.4.99.20121109-8.fc18                                     
  ibus-gtk3.x86_64 0:1.4.99.20121109-8.fc18                                     
  ibus-libs.x86_64 0:1.4.99.20121109-8.fc18                                     
fixed it again.

Version-Release number of selected component (if applicable):

See above.

How reproducible:

100%

Steps to Reproduce:
1. Upgrade to the version above, Japanese input impossible.
2. Downgrade to the versions above, Japanese works again.
3.

Actual results:


Expected results:


Additional info:
Comment 1 ati.x600.fedora.14 2013-08-17 16:06:05 EDT
Same bug reported in Ubuntu forum
http://forum.ubuntu.ru/index.php?topic=226856.0
report dated by 2013-08-11, 22:06:06 ยป
Comment 2 fujiwara 2013-08-18 21:09:06 EDT
(In reply to Richard W.M. Jones from comment #0)
> Description of problem:
> 
> Updating to ibus 0:1.5.3-1.fc18 broken Japanese input completely.
> Downgrading to:

Did you see any problems when you run ibus-daemon by manual?

% ibus exit
% ibus-daemon --xim --verbose

Did you update ibus-anthy too?

# yum install ibus ibus-anthy
Comment 3 fujiwara 2013-08-28 00:22:26 EDT
I cannot reproduce your problem.
Comment 4 Richard W.M. Jones 2013-08-28 06:13:24 EDT
(In reply to fujiwara from comment #2)
> (In reply to Richard W.M. Jones from comment #0)
> > Description of problem:
> > 
> > Updating to ibus 0:1.5.3-1.fc18 broken Japanese input completely.
> > Downgrading to:
> 
> Did you see any problems when you run ibus-daemon by manual?
> 
> % ibus exit
> % ibus-daemon --xim --verbose

There is no output from the second command at all.

It still doesn't work.

> Did you update ibus-anthy too?
> 
> # yum install ibus ibus-anthy

Yes.
Comment 5 fujiwara 2013-08-28 21:07:02 EDT
(In reply to Richard W.M. Jones from comment #0)
> 1. Upgrade to the version above, Japanese input impossible.

Would you explain your problem with detail?

Please attach your screenshot in this bug report.

% gnome-screenshot -i

Which keyboard layout do you use with ibus-anthy?

% setxkbmap -query
Comment 6 fujiwara 2013-09-02 06:31:06 EDT
Do you have any updates?
If you reopen the bug, please reply my questions.
Comment 7 Alexander Gavrilov 2013-09-09 10:55:13 EDT
Same problem here: unless I edit /usr/share/ibus-anthy/engine/default.xml and change the language field from ja to jpn, it doesn't even appear anywhere in the list.

Btw, I note that some apps like kwrite lose ability to enter pre-edit mode and do anthy input if ibus is restarted; they have to be restarted too to fix it.
Comment 8 fujiwara 2013-09-09 22:13:02 EDT
(In reply to Alexander Gavrilov from comment #7)
> Same problem here: unless I edit /usr/share/ibus-anthy/engine/default.xml
> and change the language field from ja to jpn, it doesn't even appear
> anywhere in the list.

I don't ask it. See comment #5 and editing language tag is wrong.
Comment 9 Alexander Gavrilov 2013-09-10 03:55:03 EDT
Could be also because I deleted the old ~/.config/ibus-anthy/engines.xml - I tried reverting that jpn edit to original and it seems to work now.
Comment 10 fujiwara 2013-09-10 04:27:11 EDT
(In reply to Alexander Gavrilov from comment #9)
> Could be also because I deleted the old ~/.config/ibus-anthy/engines.xml - I
> tried reverting that jpn edit to original and it seems to work now.

Your problem would not be this bug.

Note You need to log in before you can comment on or make changes to this bug.