Bug 998206 - Eclipse equinox dependency
Eclipse equinox dependency
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: freemind (Show other bugs)
19
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: hannes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 05:33 EDT by Germano Massullo
Modified: 2013-08-19 04:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 03:23:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Massullo 2013-08-18 05:33:09 EDT
Description of problem:
why does Freemind have eclipse-equinox-osgi as dependency? I found out this problem yesterday while removing all Eclipse packages from my computer. To remove them I had to remove Freemind too, and now that I am reinstalling Freemind, the computer is installing the package eclipse-equinox-osgi again.
Comment 1 hannes 2013-08-18 10:03:05 EDT
So what exactly is the problem? It's a dependency and I don't think it really hurts.
There is a bit more background, but really I don't really see the bug.
https://bugzilla.redhat.com/show_bug.cgi?id=904177
Comment 2 Germano Massullo 2013-08-18 10:06:37 EDT
I don't know why Freemind needs a component of a software IDE like Eclipse
Comment 3 hannes 2013-08-19 03:23:41 EDT
It's not freemind but xbean and I didn't invent those dependencies. For more information please take a look at the closed bug.
Comment 4 Mikolaj Izdebski 2013-08-19 04:56:17 EDT
Apache XBean requires an OSGi framework, Eclipse Equinox is one of them.
xbean spec file has a conditional that allows it to be built with Apache Felix as OSGi framework, but Equinox is used by default since that's what upstream uses.

Note You need to log in before you can comment on or make changes to this bug.