This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 998280 - During commit a snapshot get error - live merge completed for an unexpected path
During commit a snapshot get error - live merge completed for an unexpected path
Status: CLOSED DUPLICATE of bug 878975
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity low
: ---
: 3.3.0
Assigned To: Federico Simoncelli
vvyazmin@redhat.com
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 17:10 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 14:45 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 16:54:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm (4.45 MB, application/x-gzip)
2013-08-18 17:10 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-08-18 17:10:17 EDT
Created attachment 787848 [details]
## Logs rhevm, vdsm, libvirt, thread dump, superVdsm

Description of problem:
During commit a snapshot get error - live merge completed for an unexpected path

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS10 environment:

RHEVM:  rhevm-3.3.0-0.15.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.10-1.el6ev.noarch
VDSM:  vdsm-4.12.0-61.git8178ec2.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
Create VM with one or more disk
Create a snapshot
Preview a snapshot
Commit the snapshot
Successfully finish task

Actual results:
Get an error: Live merge completed for an unexpected path

Expected results:
No error should be found

Impact on user:
none

Workaround:
not relevant

Additional info:

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log

libvirtEventLoop::ERROR::2013-08-18 20:05:35,855::vm::3784::vm.Vm::(_onBlockJobEvent) vmId=`3ed567d0-9028-4b14-aec2-0c9d8b52aa7e`::Live merge completed for an unexpected path: /
rhev/data-center/1e157529-0537-4696-8a6d-9b4be4680e44/561ce535-9830-49a3-975b-ac5fa2915cce/images/fd32317c-2c3f-4dfe-bf77-23bb2c1b878f/5c1fe0d2-44de-486d-9f40-885ef618f33f
Comment 1 Federico Simoncelli 2013-08-20 04:50:35 EDT
(In reply to vvyazmin@redhat.com from comment #0)
> Steps to Reproduce:
> Create VM with one or more disk
> Create a snapshot
> Preview a snapshot
> Commit the snapshot
> Successfully finish task

The steps are incomplete, the issue is related to a live storage migration command issued at:

2013-08-14 17:01:57,633 INFO  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (pool-5-thread-43) [6ab44879] Running command: LiveMigrateVmDisksCommand Task handler: LiveSnapshotTaskHandler internal: false. Entities affected :  ID: fb5f8061-5b3c-4263-963d-2e5ea8f3ff57 Type: Disk,  ID: f29f1f15-944f-4f49-a59d-41e41ff57e8a Type: Storage

The "Live merge completed for an unexpected path" error is a text-only issue triggered by the fact that libvirt uses the same event for the disk replica and live merge.
Comment 2 Ayal Baron 2013-08-21 01:14:47 EDT
(In reply to Federico Simoncelli from comment #1)
> (In reply to vvyazmin@redhat.com from comment #0)
> > Steps to Reproduce:
> > Create VM with one or more disk
> > Create a snapshot
> > Preview a snapshot
> > Commit the snapshot
> > Successfully finish task
> 
> The steps are incomplete, the issue is related to a live storage migration
> command issued at:
> 
> 2013-08-14 17:01:57,633 INFO 
> [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (pool-5-thread-43)
> [6ab44879] Running command: LiveMigrateVmDisksCommand Task handler:
> LiveSnapshotTaskHandler internal: false. Entities affected :  ID:
> fb5f8061-5b3c-4263-963d-2e5ea8f3ff57 Type: Disk,  ID:
> f29f1f15-944f-4f49-a59d-41e41ff57e8a Type: Storage
> 
> The "Live merge completed for an unexpected path" error is a text-only issue
> triggered by the fact that libvirt uses the same event for the disk replica
> and live merge.

So is this a libvirt bug?
Is there anything that failed?
Comment 3 Federico Simoncelli 2013-08-21 14:14:22 EDT
(In reply to Ayal Baron from comment #2)
> (In reply to Federico Simoncelli from comment #1)
> > (In reply to vvyazmin@redhat.com from comment #0)
> > > Steps to Reproduce:
> > > Create VM with one or more disk
> > > Create a snapshot
> > > Preview a snapshot
> > > Commit the snapshot
> > > Successfully finish task
> > 
> > The steps are incomplete, the issue is related to a live storage migration
> > command issued at:
> > 
> > 2013-08-14 17:01:57,633 INFO 
> > [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (pool-5-thread-43)
> > [6ab44879] Running command: LiveMigrateVmDisksCommand Task handler:
> > LiveSnapshotTaskHandler internal: false. Entities affected :  ID:
> > fb5f8061-5b3c-4263-963d-2e5ea8f3ff57 Type: Disk,  ID:
> > f29f1f15-944f-4f49-a59d-41e41ff57e8a Type: Storage
> > 
> > The "Live merge completed for an unexpected path" error is a text-only issue
> > triggered by the fact that libvirt uses the same event for the disk replica
> > and live merge.
> 
> So is this a libvirt bug?
> Is there anything that failed?

Nothing failed and what happened is by design as far as I understand: libvirt fires an event at the end of a blockjob.
Live storage migration has been implemented on top of blockjob and therefore we now need to add some logic to understand what the event is referring to.
Comment 4 Ayal Baron 2013-09-02 11:10:16 EDT
Fede, isn't this a dup of bug 878975 ?
If so, please close.
Comment 5 Federico Simoncelli 2013-09-02 16:54:47 EDT
(In reply to Ayal Baron from comment #4)
> Fede, isn't this a dup of bug 878975 ?
> If so, please close.

Ah yes it is. I had the feeling there was one already but I couldn't find it.

*** This bug has been marked as a duplicate of bug 878975 ***

Note You need to log in before you can comment on or make changes to this bug.