Bug 998292 - I have a graphical trouble with Mate + Radeon when i am on lightdm and on the desktop.
I have a graphical trouble with Mate + Radeon when i am on lightdm and on the...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: radeontool (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-18 20:31 EDT by brain71
Modified: 2015-02-17 11:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:49:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brain71 2013-08-18 20:31:08 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0
Build Identifier: 

When i run Linux Fedora 19 with the kernel 3.10.5-201.fc19.x86_64 i have 
a graphical problem when i arrive to lightgdm and after on the desktop .



Reproducible: Always

Steps to Reproduce:
1.When i run Mate with the kernel 3.10.5-201.fc19.x86_64
2.
3.
Actual Results:  
I can't see correctly the desktop .

Expected Results:  
i should have a beautiful desktop ! :D

you can see a print screen here : 

http://img15.hostingpics.net/pics/305545Capture1.png

It s important , i don't have this when i use the kernel 3.9.2-301.fc19.x86_64 .

I have maked a cat : 

 cat /proc/bus/pci/devices | grep VGA || lspci | grep VGA | colrm 1 4 ; cat /proc/cpuinfo | egrep "model name|MHz" ; xdpyinfo -display :0 | egrep "version:|dimensions|depth of" ; glxinfo -display :0 | egrep -A2 "rendering|OpenGL" ; uname -sr;
0.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV740 PRO [Radeon HD 4770]
model name	: AMD Phenom(tm) 9650 Quad-Core Processor
cpu MHz		: 1150.000
model name	: AMD Phenom(tm) 9650 Quad-Core Processor
cpu MHz		: 2300.000
model name	: AMD Phenom(tm) 9650 Quad-Core Processor
cpu MHz		: 1150.000
model name	: AMD Phenom(tm) 9650 Quad-Core Processor
cpu MHz		: 1150.000
  dimensions:    1920x1080 pixels (508x285 millimeters)
  depth of root window:    24 planes
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.4
--
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV740
OpenGL core profile version string: 3.1 (Core Profile) Mesa 9.2.0-devel
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
    GL_AMD_conservative_depth, GL_AMD_draw_buffers_blend, 
    GL_AMD_shader_stencil_export, GL_ARB_ES2_compatibility, 
--
OpenGL version string: 3.0 Mesa 9.2.0-devel
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
    GL_AMD_conservative_depth, GL_AMD_draw_buffers_blend, 
    GL_AMD_shader_stencil_export, GL_APPLE_packed_pixels, 
Linux 3.9.2-301.fc19.x86_64



I use this mesa package : 

yum list installed mesa*
Modules complémentaires chargés : langpacks, refresh-packagekit
Paquets installés
mesa-demos.x86_64                       8.1.0-3.fc19                   @fedora  
mesa-dri-drivers.x86_64                 9.2-0.14.20130723.fc19         @updates 
mesa-filesystem.x86_64                  9.2-0.14.20130723.fc19         @updates 
mesa-libEGL.x86_64                      9.2-0.14.20130723.fc19         @updates 
mesa-libEGL-devel.x86_64                9.2-0.14.20130723.fc19         @updates 
mesa-libGL.x86_64                       9.2-0.14.20130723.fc19         @updates 
mesa-libGL-devel.x86_64                 9.2-0.14.20130723.fc19         @updates 
mesa-libGLES.x86_64                     9.2-0.14.20130723.fc19         @updates 
mesa-libGLES-devel.x86_64               9.2-0.14.20130723.fc19         @updates 
mesa-libGLU.x86_64                      9.0.0-2.fc19                   @anaconda
mesa-libGLU-devel.x86_64                9.0.0-2.fc19                   @fedora  
mesa-libGLw.x86_64                      8.0.0-2.fc19                   @fedora  
mesa-libGLw-devel.x86_64                8.0.0-2.fc19                   @fedora  
mesa-libOSMesa.x86_64                   9.2-0.14.20130723.fc19         @updates 
mesa-libOSMesa-devel.x86_64             9.2-0.14.20130723.fc19         @updates 
mesa-libgbm.x86_64                      9.2-0.14.20130723.fc19         @updates 
mesa-libgbm-devel.x86_64                9.2-0.14.20130723.fc19         @updates 
mesa-libglapi.x86_64                    9.2-0.14.20130723.fc19         @updates 
mesa-libwayland-egl.x86_64              9.2-0.14.20130723.fc19         @updates 
mesa-libwayland-egl-devel.x86_64        9.2-0.14.20130723.fc19         @updates 
mesa-libxatracker.x86_64                9.2-0.14.20130723.fc19         @updates 
mesa-libxatracker-devel.x86_64          9.2-0.14.20130723.fc19         @updates 
mesa-vdpau-drivers.x86_64               9.2-0.14.20130723.fc19         @updates 

If you want other addtional information say me ; )
Comment 1 brain71 2013-08-18 20:39:11 EDT
Important : I have lost the vertical synchronization with my 3D card .
Comment 2 brain71 2013-08-19 19:22:52 EDT
I have tested this with ne new kernel 3.10.7-200 after an update , it s the same problem again ..
Comment 3 brain71 2013-08-26 18:32:48 EDT
It s the same thing with the latest kernel 3.10.9.200 . I have again the problem.
Comment 4 brain71 2013-09-03 18:47:24 EDT
With the new kernel 3.10.10-200.fc19.x86_64 the graphical problem disappeared.

But i have always a bug with the the vertical synchronization , 
When i want to use driconf with it ,i have this message : 
ATTENTION: default value of option vblank_mode overridden by environment.
Comment 5 Fedora End Of Life 2015-01-09 14:30:25 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2015-02-17 11:49:26 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.