Bug 998349 - RHEL6 qemu-kvm has no "-M rhel5.6.0" Machine Type
RHEL6 qemu-kvm has no "-M rhel5.6.0" Machine Type
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Ronen Hod
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 01:41 EDT by zhonglinzhang
Modified: 2014-12-14 19:53 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-17 10:41:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhonglinzhang 2013-08-19 01:41:41 EDT
Description of problem:
As subject, The latest RHEL6.5 qemu-kvm has no "-M rhel5.6.0"
RHEL6.3 and RHEL6.4 release qemu-kvm version also haven't "-M rhel5.6.0", Not sure if need to it.

Version-Release number of selected component (if applicable):
kernel: 2.6.32-407.el6.x86_64
qemu-kvm: qemu-kvm-0.12.1.2-2.386.el6.x86_64  / 
qemu-kvm-0.12.1.2-2.389.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:
RHEL6.5 qemu-kvm has no "-M rhel5.6.0"
/usr/libexec/qemu-kvm -M ?
Supported machines are:
pc         RHEL 6.5.0 PC (alias of rhel6.5.0)
rhel6.5.0  RHEL 6.5.0 PC (default)
rhel6.4.0  RHEL 6.4.0 PC
rhel6.3.0  RHEL 6.3.0 PC
rhel6.2.0  RHEL 6.2.0 PC
rhel6.1.0  RHEL 6.1.0 PC
rhel6.0.0  RHEL 6.0.0 PC
rhel5.5.0  RHEL 5.5.0 PC
rhel5.4.4  RHEL 5.4.4 PC
rhel5.4.0  RHEL 5.4.0 PC

Expected results:

Additional info:
Comment 2 Ademar Reis 2013-08-26 11:18:17 EDT
The last machine type introduced in RHEL5's qemu is rhel5.6.0, as part of the fix for Bug #603026 (by Paolo).

Should the rhel5.6.0 machine type be supported in RHEL6 as well?

If I understood the fix for Bug #603026 correctly, users should be upgrading their machine types on RHEL5 to rhel5.6.0, which is an extra reason to support it in RHEL6.

I guess the reason we don't have rhel5.7.0 and above machine types in RHEL5 is because the hardware has not changed at all. Is that correct?
Comment 3 Paolo Bonzini 2013-08-29 11:14:31 EDT
Even the hardware of rhel5.6.0 is the same as rhel5.5.0.  Only the migration format is different.
Comment 4 Ademar Reis 2013-09-17 17:04:10 EDT
(In reply to Paolo Bonzini from comment #3)
> Even the hardware of rhel5.6.0 is the same as rhel5.5.0.  Only the migration
> format is different.

But then does it mean users should be using the rhel5.6.0 machine type instead? In other words: should we fix this bug in RHEL-6.5?
Comment 5 Paolo Bonzini 2013-09-18 04:08:13 EDT
No one is likely using the RHEL5 machine types in RHEL6, but it is simple and safe so I think it should be fixed.
Comment 6 Ademar Reis 2013-10-01 10:21:36 EDT
(In reply to Paolo Bonzini from comment #5)
> No one is likely using the RHEL5 machine types in RHEL6, but it is simple
> and safe so I think it should be fixed.

OK. It's now too late for 6.5, but let's fix it in 6.6. Took the liberty and devel_ack'd it.

Note You need to log in before you can comment on or make changes to this bug.