Bug 998415 - Spring portlet in version 2.5.6.SEC03 is not working
Spring portlet in version 2.5.6.SEC03 is not working
Status: VERIFIED
Product: JBoss Enterprise Portal Platform 6
Classification: JBoss
Component: Portal (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: CR01
: 6.1.0
Assigned To: Ken Finnigan
Dominik Pospisil
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 05:04 EDT by Petr Mensik
Modified: 2015-08-02 19:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spring portlet (30.00 KB, application/x-tar)
2013-08-30 04:39 EDT, Petr Mensik
no flags Details

  None (edit)
Description Petr Mensik 2013-08-19 05:04:58 EDT
As mentioned in the header, spring portlets don't seem to work in JPP with version 2.5.6.SEC03. The problem is that portlet is not able to find any handlers for requests, exception is

Could not complete request: javax.portlet.UnavailableException: No handler found for request


Steps to reproduce

Deploy the enclosed portlet to the JPP.
Comment 4 Petr Mensik 2013-08-30 04:39:18 EDT
Created attachment 792088 [details]
Spring portlet
Comment 5 Petr Mensik 2013-08-30 04:52:47 EDT
Hello Thomas, I've attached the portlet which shows the above error. However, you can't reproduce this with versions 3.+ because they have different settings, so if you try to build this portlet with, for instance, 3.1.4.RELEASE then you will get deployment errors. 

But at least one of the methods written in the Controller should work according to the documentation.

Note You need to log in before you can comment on or make changes to this bug.