Bug 998416 - Dist-geo-rep : geo-rep create force succeeds even if the master doesn't have the passwd less ssh to slave host
Dist-geo-rep : geo-rep create force succeeds even if the master doesn't have ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Avra Sengupta
M S Vishwanath Bhat
:
Depends On:
Blocks: 999531
  Show dependency treegraph
 
Reported: 2013-08-19 05:08 EDT by Vijaykumar Koppad
Modified: 2016-05-31 21:56 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 999531 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:38:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-08-19 05:08:30 EDT
Description of problem: geo-rep create force or geo-rep create push-pem force succeeds even if the master host doesn't have passwdless ssh connection to slave-host provided in the geo-rep command


Version-Release number of selected component (if applicable):glusterfs-3.4.0.20rhs-2.el6rhs.x86_64


How reproducible:happens everytime 


Steps to Reproduce:
1.create and start a master and slave volume.
2.Don't create passwdless ssh connection to slave host
3.do geo-rep create push-pem force

Actual results:geo-rep command succeeds  succeeds 


Expected results:It shouldn't succeed if it fails to get the  slave info


Additional info:
Comment 2 Amar Tumballi 2013-08-21 10:04:54 EDT
https://code.engineering.redhat.com/gerrit/#/c/11720
Comment 3 M S Vishwanath Bhat 2013-09-05 08:35:04 EDT
Tested in version: glusterfs-3.4.0.30rhs-2.el6rhs.x86_64


[root@mustang ~]# gluster v geo master falcon::slave create
Passwordless ssh login has not been setup with falcon.
geo-replication command failed
[root@mustang ~]# gluster v geo master falcon::slave create force
Passwordless ssh login has not been setup with falcon.
geo-replication command failed

Moving to Verified.
Comment 4 Scott Haines 2013-09-23 18:38:51 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:41:31 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.