Bug 998438 - [origin_runtime_156]Failed to save snapshot for python-2.7 app with mongodb after migration
[origin_runtime_156]Failed to save snapshot for python-2.7 app with mongodb a...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 06:20 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-29 08:52:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-08-19 06:20:56 EDT
Description of problem:
When add mongodb-2.2 to a python-2.7 app, then do save snapshot for this app after migration,will meet "OpenShift::Runtime::Utils::ShellExecutionException" errors.

Version-Release number of selected component (if applicable):
devenv_stage_442 to devenv_3672

How reproducible:
always

Steps to Reproduce:
1. Create a python-2.7 with mongo
rhc app create cpy27all python-2.7 mongodb-2.2
2. Do upgrade and migrate
3. Save snapshot for this app
rhc snapshot save cpy27all

Actual results:
<--------snip-------->
/opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:1137:in `block in do_control_with_directory': Failed to execute: 'control pre-snapshot' for /var/lib/openshift/23f4dcd8089511e3b1ea22000aec9ab0/mongodb (OpenShift::Runtime::Utils::ShellExecutionException)
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:946:in `process_cartridges'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:1105:in `do_control_with_directory'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:968:in `do_control'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:57:in `block in snapshot'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:78:in `block in each_cartridge'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:952:in `block in process_cartridges'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:950:in `each'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:950:in `process_cartridges'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/v2_cart_model.rb:76:in `each_cartridge'
	from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-node-1.13.6/lib/openshift-origin-node/model/application_container_ext/snapshots.rb:56:in `snapshot'
	from /usr/bin/gear:295:in `block (2 levels) in <main>'
	from /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
	from /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:180:in `call'
	from /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/command.rb:155:in `run'
	from /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:385:in `run_active_command'
	from /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/runner.rb:62:in `run!'
	from /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/delegates.rb:11:in `run!'
	from /opt/rh/ruby193/root/usr/share/gems/gems/commander-4.0.3/lib/commander/import.rb:10:in `block in <top (required)>'
Error in trying to save snapshot. You can try to save manually by running:
ssh 23f4dcd8089511e3b1ea22000aec9ab0@cpy27all-cdm.dev.rhcloud.com 'snapshot' > cpy27all.tar.gz


Expected results:
Save snapshot for python-2.7 app with mongodb after migration should be successfully.

Additional info:
Comment 1 Rob Millner 2013-08-19 17:15:56 EDT
Was not able to reproduce.  Started with devenv-stage_442, ran through the upgrade and migration procedure described in the release notes and then did gear upgrades.

# rhc snapshot save cpy27all
Pulling down a snapshot to cpy27all.tar.gz...
Creating and sending tar.gz

RESULT:
Success


Its possible there was a migration issue that was corrected while fixing another bug.  Passing back to Q/E to see if the problem is repeatable.
Comment 2 chunchen 2013-08-20 05:19:04 EDT
It's fixed, verified on devenv-stage_442 to devenv_3676.

Note You need to log in before you can comment on or make changes to this bug.