Bug 998440 - RHS-C: RFE: Provide a button in UI to trigger "rhsc-log-collector" and download the tar ball generated
RHS-C: RFE: Provide a button in UI to trigger "rhsc-log-collector" and downlo...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Sahina Bose
RamaKasturi
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 06:23 EDT by Prasanth
Modified: 2016-09-09 01:20 EDT (History)
13 users (show)

See Also:
Fixed In Version: rhsc-3.1.0-57
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-05-29 08:30:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanth 2013-08-19 06:23:38 EDT
Description of problem:

rhsc-log-collector should be integrated with the GUI (Console) by providing an option to the user, which when triggered, should collect sosreports from the Engine and from the selected Storage nodes in the cluster. Once collected:

* It should be either made available to download from the Console and/or 
* Provide an option to the user to upload to a remote Dropbox kind of file server.

User should be provided with an option to select the specific server(s) from which sosreports has to be collected as sosreports from all the nodes might not be required in most of the cases.

This feature, when introduced, will definitely make the life easier for an admin as he/she can download the sosreports from the required storage nodes in a single click. This is also useful if a customer is asked to gather sosreports by the support team for debugging any support cases as the same can be generated and uploaded directly to the support Dropbox from the UI.
Comment 4 Sahina Bose 2015-03-27 07:45:37 EDT
This feature is available already RHS-C 2.1.2 as part of GSS support plugin
Moving to ON_QA.
Please mark it duplicate if there's another bug
Comment 5 RamaKasturi 2015-05-22 03:15:55 EDT
Please provide the fixed in version.
Comment 6 RamaKasturi 2015-05-27 06:10:56 EDT
Moving this bug back because it does not have the ability to download the tar ball generated and upload sos report to FTP/Dropbox server.

Please close this bug if we are not going to take it in for this release.
Comment 8 Keith Robertson 2015-05-29 08:30:32 EDT
(In reply to RamaKasturi from comment #6)
> Moving this bug back because it does not have the ability to download the
> tar ball generated and upload sos report to FTP/Dropbox server.
> 
> Please close this bug if we are not going to take it in for this release.

We will not be adding the capability to upload a SoS report to a FTP/Dropbox server to the Red Hat Access plug-in for RHS-C.  That is outside the scope of the plug-in and not something that is on the roadmap.

Note You need to log in before you can comment on or make changes to this bug.