Bug 998448 - [abrt] gnome-screensaver-2.28.3-27.el6: find_usable_monitor: Process /usr/bin/gnome-screensaver was killed by signal 11 (SIGSEGV)
[abrt] gnome-screensaver-2.28.3-27.el6: find_usable_monitor: Process /usr/bin...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-screensaver (Show other bugs)
6.5
x86_64 Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
abrt_hash:fe4b3e8b3d4cd3da75516747f39...
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 06:51 EDT by Tomas Dolezal
Modified: 2014-01-02 04:04 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.28.3-28.el6
Doc Type: Bug Fix
Doc Text:
No DOCS required. problem found and fixed in unreleased gnome-screensaver package.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:30:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (24.95 KB, text/plain)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: environ (943 bytes, text/plain)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: var_log_messages (698 bytes, text/plain)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: open_fds (641 bytes, text/plain)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: dso_list (6.46 KB, text/plain)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: sosreport.tar.xz (1.77 MB, application/octet-stream)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: backtrace (37.45 KB, text/plain)
2013-08-19 06:51 EDT, Tomas Dolezal
no flags Details
File: build_ids (2.96 KB, text/plain)
2013-08-19 06:52 EDT, Tomas Dolezal
no flags Details
File: last_occurrence (10 bytes, text/plain)
2013-08-19 06:52 EDT, Tomas Dolezal
no flags Details
File: cgroup (88 bytes, text/plain)
2013-08-19 06:52 EDT, Tomas Dolezal
no flags Details

  None (edit)
Description Tomas Dolezal 2013-08-19 06:51:12 EDT
Description of problem:
automatic or user invoked start of scrensaver followed by poking screen after few seconds

user's workspace reamins unlocked!


Version-Release number of selected component:
gnome-screensaver-2.28.3-27.el6

Additional info:
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        /usr/bin/gnome-screensaver --no-daemon
crash_function: find_usable_monitor
kernel:         2.6.32-358.el6.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 find_usable_monitor at gs-manager.c
: #1 find_window_at_usable_monitor at gs-manager.c
: #2 gs_manager_request_unlock at gs-manager.c
: #3 gs_marshal_BOOLEAN__VOID at gs-marshal.c
: #8 maybe_handle_activity at gs-window-x11.c
: #9 gs_window_real_motion_notify_event at gs-window-x11.c
: #10 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c
: #15 gtk_widget_event_internal at gtkwidget.c
: #16 IA__gtk_propagate_event at gtkmain.c
: #17 IA__gtk_main_do_event at gtkmain.c
Comment 1 Tomas Dolezal 2013-08-19 06:51:16 EDT
Created attachment 787994 [details]
File: maps
Comment 2 Tomas Dolezal 2013-08-19 06:51:18 EDT
Created attachment 787995 [details]
File: environ
Comment 3 Tomas Dolezal 2013-08-19 06:51:21 EDT
Created attachment 787996 [details]
File: var_log_messages
Comment 4 Tomas Dolezal 2013-08-19 06:51:26 EDT
Created attachment 787997 [details]
File: open_fds
Comment 5 Tomas Dolezal 2013-08-19 06:51:29 EDT
Created attachment 787998 [details]
File: dso_list
Comment 6 Tomas Dolezal 2013-08-19 06:51:32 EDT
Created attachment 787999 [details]
File: limits
Comment 7 Tomas Dolezal 2013-08-19 06:51:53 EDT
Created attachment 788000 [details]
File: sosreport.tar.xz
Comment 8 Tomas Dolezal 2013-08-19 06:51:57 EDT
Created attachment 788001 [details]
File: backtrace
Comment 9 Tomas Dolezal 2013-08-19 06:52:00 EDT
Created attachment 788002 [details]
File: build_ids
Comment 10 Tomas Dolezal 2013-08-19 06:52:02 EDT
Created attachment 788003 [details]
File: last_occurrence
Comment 11 Tomas Dolezal 2013-08-19 06:52:05 EDT
Created attachment 788004 [details]
File: cgroup
Comment 12 Tomas Dolezal 2013-08-19 06:53:56 EDT
package gnome-screensaver-2.28.3-24 does run without this issue
Comment 14 Tomas Dolezal 2013-08-20 06:43:40 EDT
I've tested the package -28 release in my environment, the bug seems to be fixed in it.
Comment 20 Tomas Dolezal 2013-09-30 07:58:04 EDT
Hi Michal,
yes, in that setup it crashed every time it kicked in. either by gnome or by mentioned command. Blank screen appeared and after short while (<1s) it crashed, or crashed after moving by mouse.

I've already tested the bug in my previous environment, please see comment 14
Comment 22 errata-xmlrpc 2013-11-21 18:30:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1706.html

Note You need to log in before you can comment on or make changes to this bug.