Bug 998488 - Failed to add host with vdsm version "4.12.0-rc3.3"
Failed to add host with vdsm version "4.12.0-rc3.3"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Yaniv Bronhaim
Tareq Alayan
infra
:
: 996666 (view as bug list)
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-08-19 08:37 EDT by Yaniv Bronhaim
Modified: 2016-02-10 14:22 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:16:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18296 None None None Never

  None (edit)
Description Yaniv Bronhaim 2013-08-19 08:37:36 EDT
Description of problem:
During host installation HandleVdsVersionCommand is called, in this command we check the cluster compatibility to the vdsm version that installed on the host. This can raise an exception when vdsm version is not compatible with the cluster level (in vdsm getVdsCaps we can see to which cluster vdsm is compatible, and in vdc_options tables we can see with which vdsm versions the engine can work). 

After adding the following fix - http://gerrit.ovirt.org/#/c/17719/ according to Bug 974101, we didn't verify the vdsm version as needed, and reported a wrong report. 
The fix raised a new issue, apparently now we fail adding all hosts that contain "rc" string in their release number. RpmVersion object is used to parse the version by a regex expression that doesn't accept strings as part of the release number.

Version-Release number of selected component (if applicable):
vdsm-4.12.0-rc3.3.git06ed3cc.fc18.x86_64

How reproducible:
Adding host with the above vdsm version.

Steps to Reproduce:
1. Adding the host
2. Check the fail reason - at the events log we should see vdsm version UNKNOWN

Actual results:
Host stays in installFailed

Expected results:
We should be able to add such hosts

Additional info:
Comment 1 Yaniv Bronhaim 2013-09-01 03:57:45 EDT
*** Bug 996666 has been marked as a duplicate of this bug. ***
Comment 2 Tareq Alayan 2013-09-17 07:00:22 EDT
where can i get 4.12.0-rc3.3?
Comment 5 Tareq Alayan 2013-09-22 09:30:27 EDT
installed is add successfully with https://brewweb.devel.redhat.com/buildinfo?buildID=284653
VDSM Version:
	vdsm-4.12.0-127.gitedb88bf.el6ev
Comment 6 Itamar Heim 2014-01-21 17:16:27 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:23:17 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.