Bug 998608 - SELinux is preventing /usr/bin/python2.7 from 'remove_name' accesses on the directory tmpo_cq7R.
SELinux is preventing /usr/bin/python2.7 from 'remove_name' accesses on the d...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
medium Severity medium
: ---
: ---
Assigned To: Lukas Vrabec
Fedora Extras Quality Assurance
abrt_hash:a6f1266937726049b66296128d5...
:
: 998610 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 11:19 EDT by Mark
Modified: 2013-08-24 18:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-73.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-24 18:28:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-08-19 11:19:41 EDT
Description of problem:
install RDO/packstack. 
SELinux is preventing /usr/bin/python2.7 from 'remove_name' accesses on the directory tmpo_cq7R.

*****  Plugin catchall_labels (83.8 confidence) suggests  ********************

If you want to allow python2.7 to have remove_name access on the tmpo_cq7R directory
Then you need to change the label on tmpo_cq7R
Do
# semanage fcontext -a -t FILE_TYPE 'tmpo_cq7R'
where FILE_TYPE is one of the following: swift_data_t, swift_var_run_t, var_run_t. 
Then execute: 
restorecon -v 'tmpo_cq7R'


*****  Plugin catchall (17.1 confidence) suggests  ***************************

If you believe that python2.7 should be allowed remove_name access on the tmpo_cq7R directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep swift-object-re /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:swift_t:s0
Target Context                system_u:object_r:var_t:s0
Target Objects                tmpo_cq7R [ dir ]
Source                        swift-object-re
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.6-200.fc19.x86_64 #1 SMP Mon
                              Aug 12 14:49:42 UTC 2013 x86_64 x86_64
Alert Count                   411
First Seen                    2013-08-15 15:01:40 MDT
Last Seen                     2013-08-19 09:19:09 MDT
Local ID                      6c36030e-a050-4b97-b9e7-97d226af382b

Raw Audit Messages
type=AVC msg=audit(1376925549.821:705): avc:  denied  { remove_name } for  pid=798 comm="swift-object-re" name="tmpo_cq7R" dev="dm-1" ino=1325532 scontext=system_u:system_r:swift_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=dir


type=AVC msg=audit(1376925549.821:705): avc:  denied  { rename } for  pid=798 comm="swift-object-re" name="tmpo_cq7R" dev="dm-1" ino=1325532 scontext=system_u:system_r:swift_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file


type=AVC msg=audit(1376925549.821:705): avc:  denied  { unlink } for  pid=798 comm="swift-object-re" name="object.recon" dev="dm-1" ino=1325527 scontext=system_u:system_r:swift_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file


type=SYSCALL msg=audit(1376925549.821:705): arch=x86_64 syscall=rename success=yes exit=0 a0=f66240 a1=f739c0 a2=3048bbbf88 a3=6361632f7261762f items=0 ppid=1 pid=798 auid=4294967295 uid=1001 gid=1002 euid=1001 suid=1001 fsuid=1001 egid=1002 sgid=1002 fsgid=1002 ses=4294967295 tty=(none) comm=swift-object-re exe=/usr/bin/python2.7 subj=system_u:system_r:swift_t:s0 key=(null)

Hash: swift-object-re,swift_t,var_t,dir,remove_name

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.6-200.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-20 05:02:44 EDT
*** Bug 998610 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2013-08-23 11:12:36 EDT
selinux-policy-3.12.1-73.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-73.fc19
Comment 4 Fedora Update System 2013-08-23 19:59:12 EDT
Package selinux-policy-3.12.1-73.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-73.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15219/selinux-policy-3.12.1-73.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-24 18:28:36 EDT
selinux-policy-3.12.1-73.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.