Bug 998610 - SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directory /var/cache/swift.
SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directo...
Status: CLOSED DUPLICATE of bug 998608
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:936516dd7d3dd10a9f0e5be9548...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 11:21 EDT by Mark
Modified: 2013-08-20 05:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 05:02:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-08-19 11:21:14 EDT
Description of problem:
installed RDO + packstack from RH guide. 
http://openstack.redhat.com/Quickstart
using the havana Reo.

http://rdo.fedorapeople.org/openstack/openstack-havana/rdo-release-havana.rpm
SELinux is preventing /usr/bin/python2.7 from 'write' accesses on the directory /var/cache/swift.

*****  Plugin catchall_labels (83.8 confidence) suggests  ********************

If you want to allow python2.7 to have write access on the swift directory
Then you need to change the label on /var/cache/swift
Do
# semanage fcontext -a -t FILE_TYPE '/var/cache/swift'
where FILE_TYPE is one of the following: swift_data_t, swift_var_run_t, var_run_t. 
Then execute: 
restorecon -v '/var/cache/swift'


*****  Plugin catchall (17.1 confidence) suggests  ***************************

If you believe that python2.7 should be allowed write access on the swift directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep swift-object-re /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:swift_t:s0
Target Context                system_u:object_r:var_t:s0
Target Objects                /var/cache/swift [ dir ]
Source                        swift-object-re
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-3.fc19.x86_64
Target RPM Packages           openstack-swift-1.8.0-2.fc19.noarch
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.6-200.fc19.x86_64 #1 SMP Mon
                              Aug 12 14:49:42 UTC 2013 x86_64 x86_64
Alert Count                   413
First Seen                    2013-08-15 15:01:40 MDT
Last Seen                     2013-08-19 09:19:09 MDT
Local ID                      64afebd4-6f72-458e-9831-2d2eac579d43

Raw Audit Messages
type=AVC msg=audit(1376925549.821:704): avc:  denied  { write } for  pid=798 comm="swift-object-re" name="swift" dev="dm-1" ino=1325420 scontext=system_u:system_r:swift_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=dir


type=AVC msg=audit(1376925549.821:704): avc:  denied  { add_name } for  pid=798 comm="swift-object-re" name="tmpo_cq7R" scontext=system_u:system_r:swift_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=dir


type=AVC msg=audit(1376925549.821:704): avc:  denied  { create } for  pid=798 comm="swift-object-re" name="tmpo_cq7R" scontext=system_u:system_r:swift_t:s0 tcontext=system_u:object_r:var_t:s0 tclass=file


type=SYSCALL msg=audit(1376925549.821:704): arch=x86_64 syscall=open success=yes exit=EIO a0=f66240 a1=200c2 a2=180 a3=6361632f7261762f items=0 ppid=1 pid=798 auid=4294967295 uid=1001 gid=1002 euid=1001 suid=1001 fsuid=1001 egid=1002 sgid=1002 fsgid=1002 ses=4294967295 tty=(none) comm=swift-object-re exe=/usr/bin/python2.7 subj=system_u:system_r:swift_t:s0 key=(null)

Hash: swift-object-re,swift_t,var_t,dir,write

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.6-200.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-20 05:02:44 EDT

*** This bug has been marked as a duplicate of bug 998608 ***

Note You need to log in before you can comment on or make changes to this bug.