Bug 998640 - python-django14 : Conflicts with python-django
python-django14 : Conflicts with python-django
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-django (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Runge
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 12:31 EDT by Michael Schwendt
Modified: 2013-08-20 06:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-django-1.5.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 06:47:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Schwendt 2013-08-19 12:31:15 EDT
=> python-django14-1.4.6-1.fc20.src.rpm
=> python-django14-1.4.6-1.fc20.noarch in fedora-development-i386
  File conflict with: python3-django-1.5.2-1.fc20.noarch
     /usr/share/man/man1/django-admin.1.gz

=> python-django-1.5.2-1.fc20.src.rpm
=> python3-django-1.5.2-1.fc20.noarch in fedora-development-i386
  File conflict with: python-django14-1.4.6-1.fc20.noarch
     /usr/share/man/man1/django-admin.1.gz

[semi-automated bug report]
Comment 1 Matthias Runge 2013-08-20 01:56:14 EDT
this is intended. both versions conflict and I don't see a reason, why anyone should install both. As soon as Django-1.6 is released, django14 will be retired.
Comment 3 Matthias Runge 2013-08-20 04:51:39 EDT
http://pkgs.fedoraproject.org/cgit/python-django14.git/commit/?id=dcc9a10d96773c4c041da52b801c9ad21fc38039
introduced the Conflicts back in march this year.
I assume, this bug is targeted against python-django (reassigning)
Comment 4 Michael Schwendt 2013-08-20 05:05:28 EDT
Well, the bug is in python-django14:

https://fedoraproject.org/wiki/Packaging:Conflicts#Compat_Package_Conflicts

> Name:           python-django14
> Conflicts:      python-django >= 1.5

That's only an explicit conflict. Acceptable but should be avoided according to the guidelines.

The implicit conflict this ticket is about is between python-django14 and python3-django. It could be fixed in python-django14 when adding

  Conflicts: python3-django >= 1.5

although renaming the manual page would be the preferred solution according to the guidelines.
Comment 5 Matthias Runge 2013-08-20 06:47:35 EDT
Ah, I see. python-django obsoletes Django < 1.4.5-2. Sigh.

fixed in python-django-1.5.2-2, also renamed man pages for python3-django.

Note You need to log in before you can comment on or make changes to this bug.