Bug 998648 - kernel api changed breaks dadhi-linux
kernel api changed breaks dadhi-linux
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dahdi-tools (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeffrey C. Ollie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-19 13:06 EDT by Suhan Andrei
Modified: 2013-08-19 22:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 22:02:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhan Andrei 2013-08-19 13:06:13 EDT
Description of problem:

kernel 3.7.10 has removed create_proc_read_entry , drivers build with dadhi-linux from dahdi-tools 2.4.1-6 fails to build.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Suhan Andrei 2013-08-19 13:10:16 EDT
sorry misstyped version of kernel.
correct is :
uname -r
3.10.7-100.fc18.i686
Comment 2 Bruno Wolff III 2013-08-19 14:15:15 EDT
I have built dahdi-linux 2.7.0 with dahdi-tools 2.4.1 and had things work.

I also very recently updated dahdi-tools in rawhide to 2.7.0.

2.7.0 does have the commit to deal with the createproc API change. Though it might have been in 2.6.1.
Comment 3 Suhan Andrei 2013-08-19 14:33:34 EDT
Thanks , 

It compiles for me with upstream dahdi-linux 2.7.0 (http://downloads.asterisk.org/pub/telephony/dahdi-linux/dahdi-linux-2.7.0.tar.gz) .
Comment 4 Bruno Wolff III 2013-08-19 21:58:33 EDT
Since this is really an issue dependent on the version of dahdi-linux, not dahdi-tools, I am going to close this as not a bug.

If you regularly like to update to very recent kernels, you might want to look at the upstream git repo for fixes when you have issues. (http://git.asterisk.org/gitweb/?p=dahdi/linux.git;a=summary) Typically things get fixed before a new kernel is released.

Note You need to log in before you can comment on or make changes to this bug.